Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] OPAL_PREFIX is not passed to remote node in pls_rsh_module.c
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-10-18 08:00:50


On Oct 17, 2008, at 6:00 AM, Teng Lin wrote:

> It seems to work after I patched pls_rsh_module.c
>
>
> --- pls_rsh_module.c.orig 2008-10-16 17:15:32.000000000 -0400
> +++ pls_rsh_module.c 2008-10-16 17:15:51.000000000 -0400
> @@ -989,7 +989,7 @@
> "%s/%s/%s",
> (opal_prefix != NULL ?
> "OPAL_PREFIX=" : ""),
> (opal_prefix != NULL ?
> opal_prefix : ""),
> - (opal_prefix != NULL ? " ;" : ""),
> + (opal_prefix != NULL ? " ; export
> OPAL_PREFIX ; " : ""),
> prefix_dir, bin_base,
> prefix_dir, lib_base,
> prefix_dir, bin_base,
>
> Another workaround is to add
> export OPAL_PREFIX
> into $HOME/.bashrc.
>
> Jeff, is this a bug in the code? Or there is a reason that
> OPAL_PREFIX is not exported for sh/bash?

Yes, this is a bug -- I think your patch is correct.

Sorry about that, but thanks for the patch!

-- 
Jeff Squyres
Cisco Systems