Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OPENMPI 1.2.7 & PGI compilers: configure option --disable-ptmalloc2-opt-sbrk
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-10-15 13:42:36


On Oct 15, 2008, at 9:35 AM, Francesco Iannone wrote:

> I have a cluster of 16 nodes DualCPU DualCore AMD RAM 16 GB with
> InfiniBand
> CISCO HCA and switch InfiniBand.
> It uses Linux RH Enterprise 4 64 bit , OpenMPI 1.2.7, PGI 7.1-4 and
> openib-1.2-7.
>
> Hence it means that the option —disable-ptmalloc2 is catastrophic in
> the
> above configuration.

Actually, I notice that in your original message, you said "--disable-
ptmalloc2-opt-sbrk", but here you said "--disable-ptmalloc2". The
former is:

                           Only trigger callbacks when sbrk is used
for small
                           allocations, rather than every call to
malloc/free.
                           (default: enabled)

So it should be fine to disable; it shouldn't affect overall MPI
performance too much.

The latter disables ptmalloc2 entirely (and you'll likely get lower
benchmark bandwidth for large messages).

I'm unaware of either of these options leading to problems with the
PGI compiler suite; I have tested OMPI v1.2.x with several versions of
the PGI compiler without problem (although my latest version is PGI
7.1-4).

-- 
Jeff Squyres
Cisco Systems