Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Rmpi installation issues
From: Sean Davis (sdavis2_at_[hidden])
Date: 2008-10-13 12:18:30


On Mon, Oct 13, 2008 at 12:10 PM, Simone Giannerini
<sgiannerini_at_[hidden]> wrote:
> [...]
>
>> Your mail is basically unreadable / impossible to attribute what is
>> original and what is cited. Please follow convention and indent.
>
> I am sorry, I am copy/pasting the messages because I switched off receiving
> list mails. I forgot to ask to reply also to my personal address.
>
> Hope this one is readable
>
> [...]
>
>> Ok, didn't see that. But please do understand that 0.5-5 is on CRAN
>> and released. (And yes, that is the version for which I also had to
>> make a fix to get it build on Debian as mentioned).
>
> Ok I 'll stick to that one
>
> [...]
>
>> Not it does not as lib64 != lib. You probably it installed if you
>> create a softlink from
>
>> /usr/lib64/mpi/gcc/openmpi/lib64
>>
>> to
>
> > /usr/lib64/mpi/gcc/openmpi/lib
> >
>> Dirk
>
> Thank you, the following works for me:
>
> # ln -s /usr/lib64/mpi/gcc/openmpi/lib64/ /usr/lib64/mpi/gcc/openmpi/lib
> # CC="mpicc" R CMD INSTALL Rmpi_0.5-5.tar.gz
> --configure-args=--with-mpi=/usr/lib64/mpi/gcc/openmpi/

You can drop the --configure-args. Using the correct mpicc should
take care of all the linking, etc.

Sean