Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Passing LD_LIBRARY_PATH to orted
From: Gus Correa (gus_at_[hidden])
Date: 2008-10-10 20:46:35


Hi Craig, George, list

Here is a quick and dirty solution I used before for a similar problem.
Link the Intel libraries statically, using the "-static-intel" flag.
Other shared libraries continue to be dynamically linked.

For instance:

mipf90 -static-intel my_mpi_program.f90

What is not clear to me is why to use orted instead of
mpirun/mpiexec/orterun,
which has a mechanism to pass environment variables to the hosts
with "-x LD_LIBRARY_PATH=/my/intel/lib".

I hope this helps.
Gus Correa

-- 
---------------------------------------------------------------------
Gustavo J. Ponce Correa, PhD - Email: gus_at_[hidden]
Lamont-Doherty Earth Observatory - Columbia University
P.O. Box 1000 [61 Route 9W] - Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------
George Bosilca wrote:
> Craig,
>
> This is a problem with the Intel libraries and not the Open MPI ones.  
> You have to somehow make these libraries available on the compute nodes.
>
> What I usually do (but it's not the best way to solve this problem) 
> is  to copy these libraries somewhere on my home area and to add the  
> directory to my LD_LIBRARY_PATH.
>
>   george.
>
> On Oct 10, 2008, at 6:17 PM, Craig Tierney wrote:
>
>> I am having problems launching openmpi jobs on my system.  I support  
>> multiple versions
>> of MPI and compilers using GNU Modules.  For the default compiler,  
>> everything is fine.
>> For non-default, I am having problems.
>>
>> I built Openmpi-1.2.6 (and 1.2.7) with the following configure  options:
>>
>> # module load intel/10.1
>> # ./configure CC=icc CXX=icpc F77=ifort FC=ifort F90=ifort --prefix=/ 
>> opt/openmpi/1.2.7-intel-10.1 --without-
>> gridengine --enable-io-romio --with-io-romio-flags=--with-file- 
>> sys=nfs+ufs --with-openib=/opt/hjet/ofed/1.3.1
>>
>> When I launch a job, I run the module command for the right compiler/ 
>> MPI version to set the paths
>> correctly.  Mpirun passes LD_LIBRARY_PATH to the executable I am  
>> launching, but not orted.
>>
>> When orted is launched on the remote system, the LD_LIBRARY_PATH
>> doesn't come with, and the Intel 10.1 libraries can't be found.
>>
>> /opt/openmpi/1.2.7-intel-10.1/bin/orted: error while loading shared  
>> libraries: libintlc.so.5: cannot open shared object file: No such  
>> file or directory
>>
>> How do others solve this problem?
>>
>> Thanks,
>> Craig
>>
>>
>> -- 
>> Craig Tierney (craig.tierney_at_[hidden])
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users