Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Passing LD_LIBRARY_PATH to orted
From: Craig Tierney (Craig.Tierney_at_[hidden])
Date: 2008-10-10 18:17:05


I am having problems launching openmpi jobs on my system. I support multiple versions
of MPI and compilers using GNU Modules. For the default compiler, everything is fine.
For non-default, I am having problems.

I built Openmpi-1.2.6 (and 1.2.7) with the following configure options:

# module load intel/10.1
# ./configure CC=icc CXX=icpc F77=ifort FC=ifort F90=ifort --prefix=/opt/openmpi/1.2.7-intel-10.1 --without-
gridengine --enable-io-romio --with-io-romio-flags=--with-file-sys=nfs+ufs --with-openib=/opt/hjet/ofed/1.3.1

When I launch a job, I run the module command for the right compiler/MPI version to set the paths
correctly. Mpirun passes LD_LIBRARY_PATH to the executable I am launching, but not orted.

When orted is launched on the remote system, the LD_LIBRARY_PATH
doesn't come with, and the Intel 10.1 libraries can't be found.

/opt/openmpi/1.2.7-intel-10.1/bin/orted: error while loading shared libraries: libintlc.so.5: cannot open shared object file: No
such file or directory

How do others solve this problem?

Thanks,
Craig

-- 
Craig Tierney (craig.tierney_at_[hidden])