Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OMPI link error with petsc 2.3.3
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2008-10-08 09:37:45


Yann,

Your whole compile process in your email below shows you using mpicc to
link your executable. Can you please try and do the following for
linkage instead?

mpif90 -fPIC -m64 -o solv_ksp solv_ksp.o
-R/opt/lib/petsc/lib/amd-64-openmpi_no_debug
-L/opt/lib/petsc/lib/amd-64-openmpi_no_debug -lpetscsnes -lpetscksp
-lpetscdm -lpetscmat -lpetscvec -lpetsc -lX11 -lsunperf -lsunmath -lm
-ldl -R/opt/mx/lib/amd64 -R/opt/SUNWhpc/HPC8.0/lib/amd64
-R/opt/SUNWhpc/HPC8.0/lib/amd64 -L/opt/SUNWhpc/HPC8.0/lib/amd64 -lmpi
-lopen-rte -lopen-pal -lnsl -lrt -lm -lsocket
-R/opt/SUNWspro/lib/amd64 -R/opt/SUNWspro/lib/amd64
-L/opt/SUNWspro/lib/amd64 -R/opt/SUNWspro/prod/lib/amd64
-L/opt/SUNWspro/prod/lib/amd64 -R/usr/ccs/lib/amd64 -L/usr/ccs/lib/amd64
-R/lib/64 -L/lib/64 -R/usr/lib/64 -L/usr/lib/64 -lm -lfui -lfai -lfsu
-lsunmath -lmtsk -lm -ldl -R/usr/ucblib

--td
> Date: Wed, 08 Oct 2008 14:14:50 +0200 From: "Yann JOBIC"
> <jobic_at_[hidden]> Subject: Re: [OMPI users] OMPI link error
> with petsc 2.3.3 To: Open MPI Users <users_at_[hidden]> Message-ID:
> <48ECA43A.1060202_at_[hidden]> Content-Type: text/plain;
> charset=ISO-8859-1; format=flowed Hello, I used cc to compile. I tried
> to use mpicc/mpif90 to compile PETSC, but it changed nothing. I still
> have the same error. I'm giving you the whole compile proccess :
> 4440p-jobic% gmake solv_ksp mpicc -o solv_ksp.o -c -fPIC -m64
> -I/opt/lib/petsc -I/opt/lib/petsc/bmake/amd-64-openmpi_no_debug
> -I/opt/lib/petsc/include -I/opt/SUNWhpc/HPC8.0/include
> -I/opt/SUNWhpc/HPC8.0/include/amd64 -I. -D__SDIR__="" solv_ksp.c mpicc
> -fPIC -m64 -o solv_ksp solv_ksp.o
> -R/opt/lib/petsc/lib/amd-64-openmpi_no_debug
> -L/opt/lib/petsc/lib/amd-64-openmpi_no_debug -lpetscsnes -lpetscksp
> -lpetscdm -lpetscmat -lpetscvec -lpetsc -lX11 -lsunperf -lsunmath -lm
> -ldl -R/opt/mx/lib/amd64 -R/opt/SUNWhpc/HPC8.0/lib/amd64
> -R/opt/SUNWhpc/HPC8.0/lib/amd64 -L/opt/SUNWhpc/HPC8.0/lib/amd64 -lmpi
> -lopen-rte -lopen-pal -lnsl -lrt -lm -lsocket -lmpi_f77 -lmpi_f90
> -R/opt/SUNWspro/lib/amd64 -R/opt/SUNWspro/lib/amd64
> -L/opt/SUNWspro/lib/amd64 -R/opt/SUNWspro/prod/lib/amd64
> -L/opt/SUNWspro/prod/lib/amd64 -R/usr/ccs/lib/amd64
> -L/usr/ccs/lib/amd64 -R/lib/64 -L/lib/64 -R/usr/lib/64 -L/usr/lib/64
> -lm -lfui -lfai -lfsu -lsunmath -lmtsk -lm -ldl -R/usr/ucblib ld:
> warning: symbol `mpi_fortran_status_ignore_' has differing sizes:
> (file /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so value=0x8; file
> /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi_f90.so value=0x14);
> /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so definition taken /usr/bin/rm
> -f solv_ksp.o Thanks for your help, Yann Terry Dontje wrote:
>> > Yann,
>> >
>> > How were you trying to link your code with PETSc? Did you use mpif90
>> > or mpif77 wrappers or were you using cc or mpicc wrappers? I ran some
>> > basic tests that test the usage of MPI_STATUS_IGNORE using mpif90 (and
>> > mpif77) and it works fine. However I was able to generate a similar
>> > error as you did when tried to link things with the cc program.
>> > If you are using cc to link could you possibly try to use mpif90 to
>> > link your code?
>> >
>> > --td
>> >
>> > Date: Tue, 07 Oct 2008 16:55:14 +0200
>> > From: "Yann JOBIC" <jobic_at_[hidden]>
>> > Subject: [OMPI users] OMPI link error with petsc 2.3.3
>> > To: Open MPI Users <users_at_[hidden]>
>> > Message-ID: <48EB7852.6070404_at_[hidden]>
>> > Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>> >
>> > Hello,
>> >
>> > I'm using openmpi 1.3r19400 (ClusterTools 8.0), with sun studio 12,
>> > and solaris 10u5
>> >
>> > I've got this error when linking a PETSc code :
>> > ld: warning: symbol `mpi_fortran_status_ignore_' has differing sizes:
>> > (file /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so value=0x8; file
>> > /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi_f90.so value=0x14);
>> > /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so definition taken
>> >
>> >
>> > Isn't it very strange ?
>> >
>> > Have you got any idea on the way to solve it ?
>> >
>> > Many thanks,
>> >
>> > Yann
>> >
>>
>>> >>
>>>
>> >
>> > _______________________________________________
>> > users mailing list
>> > users_at_[hidden]
>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> -- ___________________________ Yann JOBIC HPC engineer Polytech
> Marseille DME IUSTI-CNRS UMR 6595 Technop?le de Ch?teau Gombert 5 rue
> Enrico Fermi 13453 Marseille cedex 13 Tel : (33) 4 91 10 69 39 ou (33)
> 4 91 10 69 43 Fax : (33) 4 91 10 69 69