Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OMPI link error with petsc 2.3.3
From: Yann JOBIC (jobic_at_[hidden])
Date: 2008-10-07 12:21:21


Terry Dontje wrote:
> Yann,
>
> I'll take a look at this it looks like there definitely is an issue
> between our libmpi.so and libmpi_f90.so files.
>
> I noticed that the linkage message is a warning does the code actually
> fail when running?
>
> --td
Thanks for you fast answer.
No, the program is running and gives some good results (so far, for some
small cases).
However i don't know if we'll have some strange behavior in some cases.

Yann

> Date: Tue, 07 Oct 2008 16:55:14 +0200
> From: "Yann JOBIC" <jobic_at_[hidden]>
> Subject: [OMPI users] OMPI link error with petsc 2.3.3
> To: Open MPI Users <users_at_[hidden]>
> Message-ID: <48EB7852.6070404_at_[hidden]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Hello,
>
> I'm using openmpi 1.3r19400 (ClusterTools 8.0), with sun studio 12,
> and solaris 10u5
>
> I've got this error when linking a PETSc code :
> ld: warning: symbol `mpi_fortran_status_ignore_' has differing sizes:
> (file /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so value=0x8; file
> /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi_f90.so value=0x14);
> /opt/SUNWhpc/HPC8.0/lib/amd64/libmpi.so definition taken
>
>
> Isn't it very strange ?
>
> Have you got any idea on the way to solve it ?
>
> Many thanks,
>
> Yann
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
___________________________
Yann JOBIC
HPC engineer
Polytech Marseille DME
IUSTI-CNRS UMR 6595
Technopôle de Château Gombert
5 rue Enrico Fermi
13453 Marseille cedex 13
Tel : (33) 4 91 10 69 39
  ou  (33) 4 91 10 69 43
Fax : (33) 4 91 10 69 69