Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] build failed using intel compilers on mac os x
From: Massimo Cafaro (massimo.cafaro_at_[hidden])
Date: 2008-10-07 11:08:01


Dear all,

I tried to build the latest v1.2.7 open-mpi version on Mac OS X 10.5.5
using the intel c, c++ and fortran compilers v10.1.017 (the latest
ones released by intel). Before starting the build I have properly
configured the CC, CXX, F77 and FC environment variables (to icc and
ifort). The build failed due to undefined symbols.

I am attaching a log of the failed build process.
Any clue? Am I doing something wrong?

Also, to build a 64 bit version it is enough to supply in the
corresponding environment variables the -m64 option ?
Thank you in advance and best regards,

Massimo

-- 
*******************************************************************************************************
  Massimo Cafaro, Ph.D.                              Additional  
affiliations:
  Assistant Professor                                     National  
Nanotechnology Laboratory (NNL/CNR-INFM)
  Dept. of Engineering for Innovation         Euro-Mediterranean  
Centre for Climate Change
  University of Salento, Lecce, Italy            SPACI Consortium
  Via per Monteroni
  73100 Lecce, Italy
  Voice  +39 0832 297371
  Fax +39 0832 298173
  Web     http://sara.unile.it/~cafaro
  E-mail massimo.cafaro_at_[hidden]
               cafaro_at_[hidden]
*******************************************************************************************************