Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem launching onto Bourne shell
From: Hahn Kim (hgk_at_[hidden])
Date: 2008-10-06 21:47:30


Great, that worked, thanks! However, it still concerns me that the
FAQ page says that mpirun will execute .profile which doesn't seem to
work for me. Are there any configuration issues that could possibly
be preventing mpirun from doing this? It would certainly be more
convenient if I could maintain my environment in a single .profile
file instead of adding what could potentially be a lot of -x
arguments to my mpirun command.

Hahn

On Oct 6, 2008, at 5:44 PM, Aurélien Bouteiller wrote:

> tYou can forward your local env with mpirun -x LD_LIBRARY_PATH. As an
> alternative you can set specific values with mpirun -x
> LD_LIBRARY_PATH=/some/where:/some/where/else . More information with
> mpirun --help (or man mpirun).
>
> Aurelien
>
>
>
> Le 6 oct. 08 à 16:06, Hahn Kim a écrit :
>
>> Hi,
>>
>> I'm having difficulty launching an Open MPI job onto a machine that
>> is running the Bourne shell.
>>
>> Here's my basic setup. I have two machines, one is an x86-based
>> machine running bash and the other is a Cell-based machine running
>> Bourne shell. I'm running mpirun from the x86 machine, which
>> launches a C++ MPI application onto the Cell machine. I get the
>> following error:
>>
>> error while loading shared libraries: libstdc++.so.6: cannot open
>> shared object file: No such file or directory
>>
>> The basic problem is that LD_LIBRARY_PATH needs to be set to the
>> directory that contains libstdc++.so.6 for the Cell. I set the
>> following line in .profile:
>>
>> export LD_LIBRARY_PATH=/opt/cell/toolchain/lib/gcc/ppu/4.1.1/32
>>
>> which is the path to the PPC libraries for Cell.
>>
>> Now if I log directly into the Cell machine and run the program
>> directly from the command line, I don't get the above error. But
>> mpirun still fails, even after setting LD_LIBRARY_PATH in .profile.
>>
>> As a sanity check, I did the following. I ran the following command
>> from the x86 machine:
>>
>> mpirun -np 1 --host cab0 env
>>
>> which, among others things, shows me the following value:
>>
>> LD_LIBRARY_PATH=/tools/openmpi-1.2.5/lib:
>>
>> If I log into the Cell machine and run env directly from the command
>> line, I get the following value:
>>
>> LD_LIBRARY_PATH=/opt/cell/toolchain/lib/gcc/ppu/4.1.1/32
>>
>> So it appears that .profile gets sourced when I log in but not when
>> mpirun runs.
>>
>> However, according to the OpenMPI FAQ (http://www.open-mpi.org/
>> faq/?category=running#adding-ompi-to-path
>> ), mpirun is supposed to directly call .profile since Bourne shell
>> doesn't automatically call it for non-interactive shells.
>>
>> Does anyone have any insight as to why my environment isn't being
>> set properly? Thanks!
>>
>> Hahn
>>
>> --
>> Hahn Kim, hgk_at_[hidden]
>> MIT Lincoln Laboratory
>> 244 Wood St., Lexington, MA 02420
>> Tel: 781-981-0940, Fax: 781-981-5255
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> --
> * Dr. Aurélien Bouteiller
> * Sr. Research Associate at Innovative Computing Laboratory
> * University of Tennessee
> * 1122 Volunteer Boulevard, suite 350
> * Knoxville, TN 37996
> * 865 974 6321
>
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

--
Hahn Kim
MIT Lincoln Laboratory   Phone: (781) 981-0940
244 Wood Street, S2-252  Fax: (781) 981-5255
Lexington, MA 02420      E-mail: hgk_at_[hidden]