Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Problem building OpenMPi with SunStudio compilers
From: Raymond Muno (muno_at_[hidden])
Date: 2008-10-04 11:04:12


We are implementing a new cluster that is InfiniBand based. I am
working on getting OpenMPI built for our various compile environments.
So far it is working for PGI 7.2 and PathScale 3.1. I found some
workarounds for issues with the Pathscale compilers (seg faults) in the
OpenMPI FAQ.

When I try to build with SunStudio, I cannot even get past the configure
stage. It dies in th estage that checks for C++.

*** C++ compiler and preprocessor
checking whether we are using the GNU C++ compiler... no
checking whether CC accepts -g... yes
checking dependency style of CC... none
checking how to run the C++ preprocessor... CC -E
checking for the C++ compiler vendor... sun
checking if C++ compiler works... no
**********************************************************************
* It appears that your C++ compiler is unable to produce working
* executables. A simple test application failed to properly
* execute. Note that this is likely not a problem with Open MPI,
* but a problem with the local compiler installation. More
* information (including exactly what command was given to the
* compiler and what error resulted when the command was executed) is
* available in the config.log file in this directory.
**********************************************************************
configure: error: Could not run a simple C++ program. Aborting.

The section in config.log looks to be

================
configure:21722: CC -c -DNDEBUG conftest.cpp >&5
configure:21728: $? = 0
configure:21907: result: sun
configure:21929: checking if C++ compiler works
configure:22006: CC -o conftest -DNDEBUG conftest.cpp >&5
/usr/lib64/libm.so: file not recognized: File format not recognized
configure:22009: $? = 1
configure: program exited with status 1
configure: failed program was:
=================

The attempt to configure was done with.

./configure CC=cc CXX=CC F77=f77 FC=f90 --prefix=path_to_install

All the SunStudio binaries are at the front of the path.

I find this entry in the FAQthe SunStudio compilers

http://www.open-mpi.org/faq/?category=building#build-sun-compilers

and followed that as well, with no success. It still dies at the
configure step.

The SunStudio version is 12. The target (and compilation) platform is
AMD Opteron, Barcelona. We have been using the SunStudio compilers on
this cluster on a routine basis and have not had issues.