Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Running application with MPI_Comm_spawn() in multithreaded environment
From: Ralph Castain (rhc_at_[hidden])
Date: 2008-10-03 09:20:27


On Oct 3, 2008, at 7:14 AM, Roberto Fichera wrote:

> Ralph Castain ha scritto:
>> I committed something to the trunk yesterday. Given the complexity of
>> the fix, I don't plan to bring it over to the 1.3 branch until
>> sometime mid-to-end next week so it can be adequately tested.
> Ok! So it means that I can checkout from the SVN/trunk to get you fix,
> right?

Yes, though note that I don't claim it is fully correct yet. Still
needs testing. However, I have tested it a fair amount and it seems
okay.

If you do test it, please let me know how it goes.

Thanks
Ralph

>
>> Ralph
>>
>> On Oct 3, 2008, at 5:02 AM, Roberto Fichera wrote:
>>
>>> Ralph Castain ha scritto:
>>>> Actually, it just occurred to me that you may be seeing a problem
>>>> in
>>>> comm_spawn itself that I am currently chasing down. It is in the
>>>> 1.3
>>>> branch and has to do with comm_spawning procs on subsets of nodes
>>>> (instead of across all nodes). Could be related to this - you might
>>>> want to give me a chance to complete the fix. I have identified the
>>>> problem and should have it fixed later today in our trunk -
>>>> probably
>>>> won't move to the 1.3 branch for several days.
>>> Do you have any news about the above fix? Does the fix is already
>>> available for testing?
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users