Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] qsub - mpirun problem
From: Reuti (reuti_at_[hidden])
Date: 2008-09-29 16:45:54


Am 29.09.2008 um 22:33 schrieb Zhiliang Hu:

> At 07:37 PM 9/29/2008 +0200, Reuti wrote:
>
>>> "-l nodes=6:ppn=2" is all I have to specify the node requests:
>>
>> this might help: http://www.open-mpi.org/faq/?category=tm
>
> Essentially the examples given on this web is no difference from
> what I did.
> Only thing new is, I suppose "qsub -I " is for interactive mode.
> When I did this:
>
> qsub -I -l nodes=7 mpiblastn.sh
>
> It hangs on "qsub: waiting for job 798.nagrp2.ansci.iastate.edu to
> start".
>
>
>>> UNIX_PROMPT> qsub -l nodes=6:ppn=2 /path/to/mpi_program
>>> where "mpi_program" is a file with one line:
>>> /path/to/mpirun -np 12 /path/to/my_program
>>
>> Can you please try this jobscript instead:
>>
>> #!/bin/sh
>> set | grep PBS
>> /path/to/mpirun /path/to/my_program
>>
>> All should be handled by Open MPI automatically. With the "set" bash
>> command you will get a list with all defined variables for further
>> analysis; and where you can check for the variables set by Torque.
>>
>> -- Reuti
>
> "set | grep PBS" part had nothing in output.

Strange - you checked the .o end .e files of the job? - Reuti

>
> Zhiliang
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users