Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] how to install openmpi with a specific gcc
From: Terry Frankcombe (terry_at_[hidden])
Date: 2008-09-26 00:28:48


http://www.open-mpi.org/faq/?category=building#build-compilers

But this won't help build your app with the dusty, crumbling 2.95.
You're telling OpenMPI (and all of OpenMPI, including mpicc) to use a
specific compiler.

You need to fix your code so it's portable.

On Thu, 2008-09-25 at 20:56 -0700, Shafagh Jafer wrote:
> Hi!
> on my system the default gcc is 2.95.3. For openmpi i have installed
> gcc-3.4.6 but i kept the default gcc to stay gcc-2.95.3. Now, how can
> I configure/install openmpi with gcc-3.4.6?what options should i give
> when configuring it so that it doesnt go and pick upt the dafault
> 2.95.3 ???
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users