Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] which gcc to compile openmpi with?
From: Brock Palen (brockp_at_[hidden])
Date: 2008-09-24 23:01:18


Maybe maybe not,
I don't know anyone who has tried it with that old of a compiler.

FYI, you would be better off to start updating your code for newer
compilers (go for 4.x series)
They are much improved and most systems (like ours) can't even have
2.95 work on them at all because they are 64 bit only.

Brock Palen
www.umich.edu/~brockp
Center for Advanced Computing
brockp_at_[hidden]
(734)936-1985

On Sep 24, 2008, at 10:49 PM, Shafagh Jafer wrote:
> The problem is that I am building my entire MPI-based simulator
> with openmpi wrappers and my simulator code only compiles with
> gcc-2.95.3...any thought??does openmpi NOT work with 2.95.3??
>
> --- On Wed, 9/24/08, Terry Frankcombe <terry_at_[hidden]> wrote:
> From: Terry Frankcombe <terry_at_[hidden]>
> Subject: Re: [OMPI users] which gcc to compile openmpi with?
> To: "Open MPI Users" <users_at_[hidden]>
> Date: Wednesday, September 24, 2008, 7:19 PM
>
> Both of those are really ancient. Fortran in particular will not
> work happily with those. Why don't you install something from the
> current epoch? I run happily with gcc 4.3.2. On Wed, 2008-09-24 at
> 08:36 -0700, Shafagh Jafer wrote: > which gcc is prefered to
> compile openmpi with?? gcc-2.95.3 or > gcc-3.2.3 ??? > >
> _______________________________________________ > users mailing
> list > users_at_[hidden] > http://www.open-mpi.org/mailman/
> listinfo.cgi/users _______________________________________________
> users mailing list users_at_[hidden] http://www.open-mpi.org/
> mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users