Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Mpirun don't execute
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-09-22 08:48:12


On Sep 19, 2008, at 6:50 PM, Santolo Felaco wrote:

> Hi, I try to be clearer:
> osa_at_libertas:~$ echo $LD_LIBRARY_PATH
> /usr/local/lib:/home/osa/blcr/lib
> osa_at_libertas:~$ echo $PATH
> /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/
> games:/home/osa/blcr/bin
>
> I compile the file with mpicc, then:
> osa_at_libertas:~/prove/openmpi$ mpirun -np 2 es1
>
> The comand is blocked. Don't run. CTRL+X does not end the program.

Try ctrl-c -- that's usually the way to kill applications that appear
to have been hung.

> This is ps output:
>
> osa_at_libertas:~/prove/openmpi$ mpirun -np 2 es1 &
> [1] 6151
> osa_at_libertas:~/prove/openmpi$ ps
> PID TTY TIME CMD
> 6135 pts/2 00:00:00 bash
> 6151 pts/2 00:00:00 mpirun
> 6153 pts/2 00:00:00 ssh
> 6161 pts/2 00:00:00 ps

What is your program doing? Can you tell if it's getting past
MPI_INIT, or even launching at all? Can you mpirun non-MPI
applications, such as "hostname" and "uptime"?

Are you launching this es1 application locally or remotely? From your
command line and previous description, I *assume* that it's local, but
I see an "ssh" in your ps output, possibly meaning that mpirun has
launched the application remotely (e.g., if you specified a default
hostfile or somesuch).

-- 
Jeff Squyres
Cisco Systems