Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Mpirun don't execute
From: Santolo Felaco (ahuramazda10_at_[hidden])
Date: 2008-09-19 18:50:43


Hi, I try to be clearer:
osa_at_libertas:~$ echo $LD_LIBRARY_PATH
/usr/local/lib:/home/osa/blcr/lib
osa_at_libertas:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/osa/blcr/bin

I compile the file with mpicc, then:
osa_at_libertas:~/prove/openmpi$ mpirun -np 2 es1

The comand is blocked. Don't run. CTRL+X does not end the program.

This is ps output:

osa_at_libertas:~/prove/openmpi$ mpirun -np 2 es1 &
[1] 6151
osa_at_libertas:~/prove/openmpi$ ps
  PID TTY TIME CMD
 6135 pts/2 00:00:00 bash
 6151 pts/2 00:00:00 mpirun
 6153 pts/2 00:00:00 ssh
 6161 pts/2 00:00:00 ps

Thansk

2008/9/19 Jeff Squyres <jsquyres_at_[hidden]>

> Could you send a little more detailed explanation of exactly what is going
> wrong?
>
> Remember: the more information you include in your report, the better.
> E-mails simply stating, "It doesn't work!" are not helpful; we need to know
> as much information about your environment as possible in order to provide
> meaningful assistance. The best way to get help is to provide a "recipie"
> for reproducing the problem. This will allow the Open MPI developers to see
> the error for themselves, and therefore be able to fix it.
>
> Thanks!
>
>
>
> On Sep 19, 2008, at 4:35 PM, Santolo Felaco wrote:
>
> The attachemente contains: config.log, output file of ompi_info --all and
>> output file of ipconfig.
>> I need of version 1.3 because I must use the checkpoint.
>> Thanks.
>>
>>
>> 2008/9/19 Jeff Squyres <jsquyres_at_[hidden]>
>> Please see http://www.open-mpi.org/community/help/; this will help us
>> understand your problem.
>>
>> Also note that Open MPI v1.3 is not yet released. If you have v1.3, it's
>> a pre-release version.
>>
>>
>>
>> On Sep 19, 2008, at 1:37 PM, Santolo Felaco wrote:
>>
>> Hi, I have installed OpenMpi 1.3, my OS il Linux Ubuntu 8.04.
>> When I invoke the comand mpirun -np 1 es2 the shell is blocked. The comand
>> CTRL+X is not catched.
>> I have set defaut hostfile and I set LD_LIBRARY_PATH with /usr/local/lib.
>> Help me, please
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> --
>> Jeff Squyres
>> Cisco Systems
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> *****************************************************************************
>> **
>> **
>> ** WARNING: This email contains an attachment of a very suspicious type.
>> **
>> ** You are urged NOT to open this attachment unless you are absolutely
>> **
>> ** sure it is legitimate. Opening this attachment may cause irreparable
>> **
>> ** damage to your computer and your files. If you have any questions
>> **
>> ** about the validity of this message, PLEASE SEEK HELP BEFORE OPENING IT.
>> **
>> **
>> **
>> ** This warning was added by the IU Computer Science Dept. mail scanner.
>> **
>>
>> *****************************************************************************
>>
>> <log.zip>_______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>