Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with MPI_Send and MPI_Recv
From: Sofia Aparicio Secanellas (saparicio_at_[hidden])
Date: 2008-09-19 10:09:11


Hello Terry,

I have installed 1.2.7 and I obtain the same result.

I will explain you what I have done.

1. On my computer edu_at_10.1.10.240 I have added a new user called sofia. This
way I have sofia_at_10.1.10.208 and sofia_at_10.1.10.240.
2. I have downloaded the openmpi 1.2.7 from the openmpi website on both
computers in /home/sofia/Desktop.
3. I have installed everything using "sudo ./configure", "sudo make" and
"sudo make install".
4. To make ssh not ask me for a password. I have typed in sofia_at_10.1.10.208
"ssh-keygen -t dsa", "cd $HOME/.ssh" and "cp id_dsa.pub authorized_keys". I
have copied the directory "/home/sofia/.ssh" from sofia_at_10.1.10.208 to
/home/sofia/.ssh in sofia_at_10.1.10.240. The ssh command without password
works on computer sofia_at_10.1.10.208 but computer sofia_at_10.1.10.208 ask me
for a passphrase and for the password. Is it normal?
5. I have created a directory "/home/sofia/programasparalelos" on both
computers and I have given permissions to the directory with "chmod 777".
6. I have copied on both computers in "/home/sofia/programasparalelos" the
program "PruebaSumaParalela.c" (I have changed a little bit the program, I
enclose you the new program) and I have compiled using "mpicc
PruebaSumaParalela.c -o PruebaSumaParalela.out".

7. Now I run the program on both computersusing the command:

mpirun -np2 --host 10.1.10.208,10.1.10.240 --prefix /usr/local
./PruebaSumaParalela.out

 When I run the program I obtain 3 PIDs executing on every computer, 2 of
"./PruebaSumaParalela.out" and 1 of "mpirun -np2 --host
10.1.10.208,10.1.10.240 --prefix /usr/local ./PruebaSumaParalela.out". I
enclose you the results obtained on every computer for every
"./PruebaSumaParalela.out".

Thank you very much.

Sofia

----- Original Message -----
From: "Terry Dontje" <Terry.Dontje_at_[hidden]>
To: <users_at_[hidden]>
Sent: Thursday, September 18, 2008 7:31 PM
Subject: Re: [OMPI users] Problem with MPI_Send and MPI_Recv

> Turns out you debugged the mpirun I was actually wanting you to attach to
> your program, PruebaSumaParalela.out, on both nodes and dump each of their
> stacks.
> Is there a reason why you are using 1.2.2 instead of 1.2.7 or something
> from the 1.3 branch? I am wondering if maybe there is some sort of bug in
> the tcp BTL that is preventing it from matching your two interfaces.
>
> Another thing to try is to specifically list out the interfaces you want
> to have used. I do not think this is going to help but it can't hurt
> either. I would do something like:
>
> mpirun -np 2 --host 10.4.5.123,edu_at_10.4.5.126 --mca mpi_preconnect_all
> 1 --prefix /usr/local -mca btl self,tcp -mca btl_tcp_if_include eth1
> ./PruebaSumaParalela.out
>
>
> --td
>
> Date: Thu, 18 Sep 2008 13:12:46 +0200
> From: "Sofia Aparicio Secanellas" <saparicio_at_[hidden]>
> Subject: Re: [OMPI users] Problem with MPI_Send and MPI_Recv
> To: "Open MPI Users" <users_at_[hidden]>
> Message-ID: <35BA42AA514D45239323DB9B38B4C5CE_at_aparicio1>
> Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"
>
> Hello Terry,
>
> Finally, I have installed dbx. I enclose a file with the result that I get
> when I type "dbx - PID of mpirun..." and then "where" on computer
> 10.4.5.123 .
>
> Do you have any idea what could be the problem?
>
> Thanks a lot!!
>
> Sofia
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> No virus found in this incoming message
> Checked by PC Tools AntiVirus (4.0.0.26 - 10.100.007).
> http://www.pctools.com/free-antivirus/

No virus found in this outgoing message
Checked by PC Tools AntiVirus (4.0.0.26 - 10.100.007).
http://www.pctools.com/free-antivirus/