Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] errors returned from openmpi-1.2.7 source code
From: Shafagh Jafer (barfy27_at_[hidden])
Date: 2008-09-17 14:16:41


The openmpi is installed in the following path: /opt/openmpi/1.2.7 so should i replce what you told me about /usr/lib with /opt/openmpi/1.2.7 ??

--- On Wed, 9/17/08, Jeff Squyres <jsquyres_at_[hidden]> wrote:

From: Jeff Squyres <jsquyres_at_[hidden]>
Subject: Re: [OMPI users] errors returned from openmpi-1.2.7 source code
To: "Open MPI Users" <users_at_[hidden]>
Date: Wednesday, September 17, 2008, 9:22 AM

I don't quite understand the format of this file, but at first glance,
you shouldn't need the following lines:

export LIBMPI = -lmpi

export MPIDIR=/nfs/sjafer/phd/openMPI/installed
export LDFLAGS +=-L$(MPIDIR)/lib
export INCLUDES_CPP += -I$(MPIDIR)/include

It also doesn't seem like the last 2 arguments of this line are a good
idea (the linker should automatically put /usr/lib and /lib in your
search path, if appropriate):

export LDFLAGS+=-L. -L$/usr/lib -L$/lib

I also notice:

export CPP=mpic++
export CC=mpiCC

I think you want "mpicc" for CC (note the lower case) -- mpiCC is the
C
++ compiler (mpic++ and mpiCC are synonyms).

This might solve your problem.

On Sep 15, 2008, at 4:56 PM, Shafagh Jafer wrote:

> i am sending you my simulator's Makefile.common which points to
> openmpi, please take a look at it. Thanks a lot.
>
> --- On Mon, 9/15/08, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> From: Jeff Squyres <jsquyres_at_[hidden]>
> Subject: Re: [OMPI users] errors returned from openmpi-1.2.7 source
> code
> To: "Open MPI Users" <users_at_[hidden]>
> Date: Monday, September 15, 2008, 11:21 AM
>
> On Sep 14, 2008, at 1:24 PM, Shafagh Jafer wrote:
>
> > I installed openmpi-1.2.7 and tested the hello_c and ring_c examples
> > on single and multiple node and worked fine. However, when I use
> > openmpi with my simulator (by replacing the old mpich path with the
> > new openmpi ) I get many errors reported from "/openMPI/
> > openmpi-1.2.7/include/openmpi/ompi/mpi/cxx/*.h" . Please see the
> > following snap shots:
> >
>
> It's not clear exactly what you did here. Did you just replace
> MPICH's "mpiCC" with OMPI's "mpiCC"? FWIW,
this is
> almost always the
> easiest way to compile MPI applications: use that implementation's
> "wrapper" compiler (I'm assuming you have a C++ code in this
> case).
>
> These errors should not normally happen; they look kinda like you're
> somehow inadvertently mixing Open MPI and MPICH.
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> <Makefile.common>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users