Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with MPI_Send and MPI_Recv
From: Sofia Aparicio Secanellas (saparicio_at_[hidden])
Date: 2008-09-17 11:44:02


Hello Terry,

I was trying to do the debug. I was setting all the debugging parameters for
the MPI layer. Only with 1 parameter I obtain something different. I enclose
the result of the following command:

mpirun --mca mpi_show_mca_params 1 -np 2 --host
10.4.5.123,edu_at_10.4.5.126 --prefix /usr/local ./PruebaSumaParalela.out

Thanks again.

Sofia

----- Original Message -----
From: "Terry Dontje" <Terry.Dontje_at_[hidden]>
To: <users_at_[hidden]>
Sent: Wednesday, September 17, 2008 1:24 PM
Subject: Re: [OMPI users] Problem with MPI_Send and MPI_Recv

> Sofia,
>
> I took your program and actually ran it successfully on my systems using
> Open MPI r19400. A couple questions:
>
> 1. Have you tried to run the program on a single node?
> mpirun -np 2 --host 10.4.5.123 --prefix /usr/local
> ./PruebaSumaParalela.out
>
> 2. Can you try and run the code the following way and is the output
> different?
> mpirun -np 2 --host 10.4.5.123,edu_at_10.4.5.126 --mca mpi_preconnect_all
> 1 --prefix /usr/local ./PruebaSumaParalela.out
>
> 3. When the program hangs can you attach a debugger to one of the
> processes and print out a stack?
>
> 4. What version of Open MPI are you using, on what type of machine, using
> which OS?
>
> --td
>> Date: Tue, 16 Sep 2008 18:15:59 +0200
>> From: "Sofia Aparicio Secanellas" <saparicio_at_[hidden]>
>> Subject: [OMPI users] Problem with MPI_Send and MPI_Recv
>> To: <users_at_[hidden]>
>> Message-ID: <D99B2E131E0640C9A2A4D8A0FD2472A5_at_aparicio1>
>> Content-Type: text/plain; charset="iso-8859-1"
>>
>> Hello,
>>
>> I am new using MPI. I want to run a simple program (I enclose the
>> program) in 2 different computers. I have installed MPI in both
>> computers. I have compiled the program using:
>>
>> mpiCC -o PruebaSumaParalela.out PruebaSumaParalela.cpp
>>
>> I have copied the executable PruebaSumaParalela.out to my /home directoy
>> in both computers. Then I run:
>>
>> mpirun -np 2 --host 10.4.5.123,edu_at_10.4.5.126 --prefix /usr/local
>> ./PruebaSumaParalela.out
>> The 10.4.5.123 computer prints:
>>
>> Inicio
>> Inicio
>> totalnodes:2
>> mynode:0
>> Inicio Recv
>> totalnodes:2
>> mynode:1
>> Inicio Send
>> sum:375250
>>
>> The edu_at_10.4.5.126 computer prints:
>>
>> Inicio
>> Inicio
>> totalnodes:2
>> mynode:1
>> Inicio Send
>> sum:375250
>> totalnodes:2
>> mynode:0
>> Inicio Recv
>>
>> But the program does not finish on any computer. It seems that the Send
>> and Recv does not work. Master computer is waiting to receive something
>> that the slave does not send.
>> Do you know what the problem could be ?
>>
>> Thank you very much.
>>
>> Sofia
>>
>> No virus found in this outgoing message
>> Checked by PC Tools AntiVirus (4.0.0.26 - 10.100.007).
>> http://www.pctools.com/free-antivirus/
>> -------------- next part --------------
>> HTML attachment scrubbed and removed
>> -------------- next part --------------
>> An embedded and charset-unspecified text was scrubbed...
>> Name: PruebaSumaParalela.cpp
>> URL:
>> <http://www.open-mpi.org/MailArchives/users/attachments/20080916/d19b7a37/attachment.ksh>
>>
>> ------------------------------
>>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> No virus found in this incoming message
> Checked by PC Tools AntiVirus (4.0.0.26 - 10.100.007).
> http://www.pctools.com/free-antivirus/

No virus found in this outgoing message
Checked by PC Tools AntiVirus (4.0.0.26 - 10.100.007).
http://www.pctools.com/free-antivirus/