Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Need help resolving No route to host error with OpenMPI 1.1.2
From: Eric Thibodeau (kyron_at_[hidden])
Date: 2008-09-11 20:07:13


Jeff Squyres wrote:
> On Sep 11, 2008, at 3:27 PM, Eric Thibodeau wrote:
>
>> Ok, added to the information from the README, I'm thinking none of
>> the 3 configure options have an impact on the said 'threaded TCP
>> listener' and the MCA option you suggested should still work, is this
>> correct?
>
> It should default to --with-threads=posix, which you'll need for the
> threaded listener (it just means that the system supports posix
> threads). You can either specify that explicitly or trust configure
> to get it right (you can examine the output of configure to check that
> it got it right -- but I'm sure it did).
>
>> On that matter, since we're modifying the package to correct this,
>> how would I go about enabling `oob_tcp_listen_mode listen_thread` by
>> default at compile time?
>
> You can't at compile time, sorry. There's just too many MCA
> parameters for us to offer a configure parameter for each one of them.
>
> But you can set the global config file to set this MCA param value by
> default:
>
> http://www.open-mpi.org/faq/?category=tuning#setting-mca-params
Thanks, we're adding this as a default parameter to the openmpi package
if threads option was selected.

Eric