Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Need help resolving No route to host error with OpenMPI 1.1.2
From: Eric Thibodeau (kyron_at_[hidden])
Date: 2008-09-11 14:38:48


Jeff,

In short:

Which of the 3 options is the one known to be unstable in the following:

  --enable-mpi-threads Enable threads for MPI applications (default:
                          disabled)
  --enable-progress-threads
                          Enable threads asynchronous communication progress
                          (default: disabled)
  --with-threads Set thread type (solaris / posix)

?

In long (rationale):

    Just to make sure we don't contradict each other, you're suggesting
the use of 'listen_thread' but, at the same time I'm telling Prasanna to
_disable_ threads the threads USE flag which translates into the
following logic (in the package):

    if use threads; then
        myconf="${myconf}
            --enable-mpi-threads
            --with-progress-threads
            --with-threads=posix"
    fi

The decision was made based on the configure --help information (most
probably from the 1.1 series), which lead to arbitrarily
enabling/disabling all that has to do with threads using a single
keyword. Now, based on :

https://svn.open-mpi.org/trac/ompi/wiki/ThreadSafetySupport

So, is it only --enable-mpi-threads that is unstable in the "*thread*"
options?

Thanks,

Eric

Jeff Squyres wrote:
> On Sep 10, 2008, at 9:29 PM, Prasanna Ranganathan wrote:
>
>> I have upgraded to 1.2.7 and am still noticing the issue.
>
> FWIW, we didn't change anything with regards to OOB and TCP from 1.2.6
> -> 1.2.7, but it's still good to be at the latest version.
>
> Try running with this MCA parameter:
>
> mpirun --mca oob_tcp_listen_mode listen_thread ...
>
> Sorry; I forgot that we did not enable that option by default in the
> v1.2 series.
>