Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Need help resolving No route to host error with OpenMPI 1.1.2
From: Eric Thibodeau (kyron_at_[hidden])
Date: 2008-09-10 21:42:09


Prasanna Ranganathan wrote:
> Hi Eric,
>
> Thanks a lot for the reply.
>
> I am currently working on upgrading to 1.2.7
>
> I do not quite follow your directions; What do you refer to when you say say
> "try with USE=-threads..."
>
I am referring to the USE variable which is used to set global package
specificities. If you want to disable threads only for openmpi, edit
/etc/portage/package.use and add the following line to it:

sys-cluster/openmpi -threads

And re-emerge openmpi, this will disable threads.
> Kindly excuse if it is a silly question and pardon my ignorance :D
>
It is related to using Gentoo, if you're new to it, I suggest you give
the documentation a shot:

http://www.gentoo.org/doc/en/index.xml?catid=gentoo
> Regards,
>
> Prasanna.
>

Eric