Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems with compilig of OpenMPI 1.2.7
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-08-29 19:26:37


On Aug 29, 2008, at 9:03 AM, Paul Kapinos wrote:

> I just tried to install the 1.2.7 version of OpenMPI alongside to
> our used 1.2.5 and 1.2.6.
>
> Because we use gcc, intel, studio and pgi compilers on three OSes
> (Linux, Solaris/Sparc/ Solaris/Opteron), we have at least 15
> Versions to compile (not all compilers are available everywere).
> Some versions are configured and compiled well (so, I don't check
> them yet, but they compiled and installed...)
>
> But 8 of versions beraks the compilation with some crude error
> messages. Mostly there were logs like
>
> "/usr/include/infiniband/kern-abi.h", line 144: zero-sized struct/
> union
> "btl_openib_component.c", line 293: warning: syntax error: empty
> declaration

Can you send the full config.log and make output from at least one of
these builds?

-- 
Jeff Squyres
Cisco Systems