Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] TCP Bandwidth
From: Jon Mason (jon_at_[hidden])
Date: 2008-08-18 15:06:57


On Mon, Aug 18, 2008 at 10:00:24AM +0200, Andy Georgi wrote:
> Steve Wise wrote:
>> Are you using Chelsio's TOE drivers? Or just a driver from the distro?
>
> We use the Chelsio TOE drivers.
>
>
> Steve Wise wrote:
>> Ok. Did you run their perftune.sh script?

That script should optimally tune your NIC. If you are still not
satisfied with the performance, Chelsio should have people available to
help. Since the TOE module is not opensource, there is not much anyone
else can do. You can try tweaking any module parms that are exposed.
Checkout the modinfo output for that module.

> Yes, if not we wouldn't get the 1.15 GB/s on the TCP level. We had ~800 MB/s before
> primarily because of too small TCP buffers.
>
> The difference of more than 200 MB/s between 1.15 GB/s we get with iperf and the 930 MB/s we
> measured with a MPI-Ping-Pong test is too large, i think. Something in Open MPI seems to slow it down.

You can also try the new iWARP support in OMPI 1.3. The perf for that
should be much better.

Thanks,
Jon

> --
>
>
> Dresden University of Technology
> Center for Information Services
> and High Performance Computing (ZIH)
> D-01062 Dresden
> Germany
>
> e-mail: Andy.Georgi_at_[hidden]
> WWW: http://www.tu-dresden.de/zih
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users