Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] WIEN2k compilation using openmpi
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-08-05 18:11:47


I don't know anything about wien2k, but I do notice that the link line
of your output doesn't used mpif77 or mpif90. Is there a reason for
that? Indeed, I see the following in the link line:

     ... -L/usr/local/lib -lmpi

But you clearly installed Open MPI to /opt/intel/linux86_64. So that
doesn't seem right.

mpif77 and mpif90 add in all the support libraries and compiler/linker
flags that Open MPI needs. In general, the OMPI team recommends using
the wrapper compilers (mpif77 and mpi90) wherever possible; they can
greatly reduce your logistics in trying to get MPI apps to compile and
link successfully.

On Aug 5, 2008, at 4:52 PM, Sergio Yanuen Rodriguez wrote:

> Dear openmpi users:
>
> I am trying to compile wien2k in parallel on a intel core quad
> processor
> with fedora 8 and 8 GB in RAM but I am getting some errors. I am
> able to
> install and run the serial version.
>
> My software is:
>
> Kernel version 2.6.25
> gcc version 4.1.2
> Intel Fortran compiler 10.1.015
> Intel MKL 10.0.1.014
> OpenMPI 1.2.4
> WIEN2k_08.2
>
> The compilation options are:
> Serial Current settings:
> O Compiler options: -FR -mp1 -w -prec_div -pc80 -pad -ip
> -DINTEL_VML -O3 -xW
> L Linker Flags: $(FOPT) -L/opt/intel/mkl/10.0.1.014/lib/
> em64t
> -lpthread
> P Preprocessor flags '-DParallel'
> R R_LIB (LAPACK+BLAS): -L/opt/intel/mkl/10.0.1.014/lib/em64t
> -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lguide -lpthread
>
> Parallel Current settings:
> RP RP_LIB(SCALAPACK+PBLAS): -L /opt/intel/mkl/10.0.1.014/lib/
> em64t
> -lmkl_intel_lp64 -lmkl_scalapack_lp64 -lmkl_blacs_openmpi_lp64
> -lmkl_sequential -lmkl_core -L/usr/local/lib -lmpi
> FP FPOPT(par.comp.options): -FR -mp1 -w -prec_div -pc80 -pad -ip
> -DINTEL_VML -traceback -I /opt/intel/linux86_64/include
> MP MPIRUN commando : mpirun -np _NP_ -machinefile
> _HOSTS_ _EXEC_
>
> The errors I am getting are in the zip file attached, together with
> the
> openmpi compilation files.
>
> Any help is greatly appreciated
>
> Thank you
>
> Sergio Y. Rodriguez
> Physics Department
> Texas A&M University
> <ompi-output.tar.gz>_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems