Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Missing F90 modules
From: Ashley Pittman (apittman_at_[hidden])
Date: 2008-07-31 02:30:15


On Wed, 2008-07-30 at 10:45 -0700, Scott Beardsley wrote:
> I'm attempting to move to OpenMPI from another MPICH-derived
> implementation. I compiled openmpi 1.2.6 using the following configure:
>
> ./configure --build=x86_64-redhat-linux-gnu
> --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu
> --program-prefix= --prefix=/usr/mpi/pathscale/openmpi-1.2.6
> --exec-prefix=/usr/mpi/pathscale/openmpi-1.2.6
> --bindir=/usr/mpi/pathscale/openmpi-1.2.6/bin
> --sbindir=/usr/mpi/pathscale/openmpi-1.2.6/sbin
> --sysconfdir=/usr/mpi/pathscale/openmpi-1.2.6/etc
> --datadir=/usr/mpi/pathscale/openmpi-1.2.6/share
> --includedir=/usr/mpi/pathscale/openmpi-1.2.6/include
> --libdir=/usr/mpi/pathscale/openmpi-1.2.6/lib64
> --libexecdir=/usr/mpi/pathscale/openmpi-1.2.6/libexec
> --localstatedir=/var
> --sharedstatedir=/usr/mpi/pathscale/openmpi-1.2.6/com
> --mandir=/usr/mpi/pathscale/openmpi-1.2.6/share/man
> --infodir=/usr/share/info --with-openib=/usr
> --with-openib-libdir=/usr/lib64 CC=pathcc CXX=pathCC F77=pathf90
> FC=pathf90 --with-psm-dir=/usr --enable-mpirun-prefix-by-default
> --with-mpi-f90-size=large

Nothing to do with fortran but I think I'm right in saying a lot of
these command line options aren't needed, you simply set --prefix and
the rest of the options default to be relative to that.

Ashley.