Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] How to specify hosts for MPI_Comm_spawn
From: Mark Borgerding (markb_at_[hidden])
Date: 2008-07-28 12:38:39


When I add the info parameter in MPI_Comm_spawn, I get the error
"Some of the requested hosts are not included in the current allocation
for the application:
[...]
Verify that you have mapped the allocated resources properly using the
--host specification."

Here is a snippet of my code that causes the error:

    MPI_Info info;
    MPI_Info_create( &info );
    MPI_Info_set(info,"host","localhost");
    MPI_Comm_spawn( cmd , MPI_ARGV_NULL , nkids , info , 0 ,
MPI_COMM_SELF , &kid , errs );

Mark Borgerding wrote:
> Thanks, I don't know how I missed that. Perhaps I got thrown off by
> "Portable programs not requiring detailed control over process
> locations should use MPI_INFO_NULL."
>
> If there were a computing equivalent of Maslow's Hierarchy of Needs,
> functioning would be more fundamental than portability :)
>
> -- Mark
>
>
> Ralph Castain wrote:
>> Take a look at the man page for MPI_Comm_spawn. It should explain
>> that you need to create an MPI_Info key that has the key of "host"
>> and a value that contains a comma-delimited list of hosts to be used
>> for the child processes.
>>
>> Hope that helps
>> Ralph
>>
>> On Jul 28, 2008, at 8:54 AM, Mark Borgerding wrote:
>>
>>> How does openmpi decide which hosts are used with MPI_Comm_spawn?
>>> All the docs I've found talk about specifying hosts on the
>>> mpiexec/mpirun command and so are not applicable.
>>> I am unable to spawn on anything but localhost (which makes for a
>>> pretty uninteresting cluster).
>>>
>>> When I run
>>> ompi_info --param rds hostfile
>>> It reports MCA rds: parameter "rds_hostfile_path"
>>> (current value:
>>> "/usr/lib/openmpi/1.2.5-gcc/etc/openmpi-default-hostfile")
>>> I tried changing that file but it has no effect.
>>>
>>>
>>> I am using
>>> openmpi 1.2.5
>>> CentOS 5.2
>>> ethernet TCP
>>>
>>>
>>> -- Mark
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>

-- 
Mark Borgerding
3dB Labs, Inc
Innovate.  Develop.  Deliver.