Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with WRF and pgi-7.2
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-07-23 12:05:59


Hmm; I haven't seen this kind of problem before. Have you contacted
PGI?

On Jul 21, 2008, at 2:08 PM, Brock Palen wrote:

> Hi, When compiling WRF with PGI-7.2-1 with openmpi-1.2.6
> The file buf_for_proc.c fails. Nothing specail about this file
> sticks out to me. But older versions of PGI like it just fine. The
> errors PGI complains about has to do with mpi.h though:
>
> [brockp_at_nyx-login1 RSL_LITE]$ mpicc -DFSEEKO64_OK -w -O3 -
> DDM_PARALLEL -c buf_for_proc.c
> PGC-S-0036-Syntax error: Recovery attempted by inserting
> identifier .Z0000 before '(' (/home/software/rhel4/openmpi-1.2.6/
> pgi-7.0/include/mpi.h: 823)
> PGC-S-0082-Function returning array not allowed (/home/software/
> rhel4/openmpi-1.2.6/pgi-7.0/include/mpi.h: 823)
> PGC-S-0043-Redefinition of symbol, MPI_Comm (/home/software/rhel4/
> openmpi-1.2.6/pgi-7.0/include/mpi.h: 837)
> PGC/x86-64 Linux 7.2-1: compilation completed with severe errors
>
> Has anyone else seen that kind of problem with mpi.h and pgi? Do I
> need to use -c89 ? I know PGI changed the default with this a
> while back, but it does not appear to help.
>
> Thanks!
>
>
> Brock Palen
> www.umich.edu/~brockp
> Center for Advanced Computing
> brockp_at_[hidden]
> (734)936-1985
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems