Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] btl parameter is not set to openib on node with ib card
From: SLIM H.A. (h.a.slim_at_[hidden])
Date: 2008-06-17 10:49:36


Hi

OpenMPI does not pick up the infiniband component on our nodes with
Mellanox cards:

ompi_info --param btl openib

returns

MCA btl: parameter "btl_base_debug" (current value: "0")
        If btl_base_debug is 1 standard debug is output, if > 1 verbose
debug is output
MCA btl: parameter "btl" (current value: "mx,self,sm")
        Default selection set of components for the btl framework
(<none> means "use all components that can
                          be found")
MCA btl: parameter "btl_base_verbose" (current value: "0")
        Verbosity level for the btl framework (0 = no verbosity)
MCA btl: parameter "btl_base_warn_component_unused" (current value: "1")
        This parameter is used to turn on warning messages when certain
NICs are not used

Note that the btl parameter has the value "mx,self,sm".

I have configured openmpi-1.2.5 with the --with-openib=dir and
--with-mx=dir switches
and with ofed-1.2. This is part of the config output:

--- MCA component btl:mx (m4 configuration macro)
checking for MCA component btl:mx compile mode... dso
checking myriexpress.h usability... yes
checking myriexpress.h presence... yes
checking for myriexpress.h... yes
looking for library in lib
checking for mx_finalize in -lmyriexpress... yes
checking for MX version 1.0 or later... yes
checking for MX_API...
checking for a MX version with mx_register_match_callback... yes
checking if MCA component btl:mx can compile... yes

--- MCA component btl:openib (m4 configuration macro)
checking for MCA component btl:openib compile mode... dso
checking infiniband/verbs.h usability... yes
checking infiniband/verbs.h presence... yes
checking for infiniband/verbs.h... yes
checking for ibv_open_device in -libverbs... yes
checking number of arguments to ibv_create_cq... 5
checking for ibv_create_srq... yes
checking for ibv_get_device_list... yes
checking for ibv_resize_cq... yes
checking for ibv_fork_init... yes
checking if MCA component btl:openib can compile... yes

It appears the configuraion for both interconnects succeeded.

Why does ompi_info find the mx btl instead of openib?

Thanks for any advice

Henk