Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] help me please, about Open MPI
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-06-17 09:10:18


Is /tmp writable on your compute nodes?

On Jun 16, 2008, at 1:49 PM, Tony Smith wrote:

> Dear Sir:
>
> thanks.
> I have changed it to its absolute path:
> /ptmp/myname/openmpi123/ompi123_install/bin/mpirun -np 8 /ptmp/
> myname/openmpi123/openmpi-1.2.3/examples/hello_c
>
> But I still got the error :
> ====================================================
> [hpc-cluster-38 :32635] [0,0,0] ORTE_ERROR_LOG: Error in file
>
> runtime/orte_init_stage1.c at line 626
> --------------------------------------------------------------------------
> It looks like orte_init failed for some reason; your parallel
> process is
> likely to abort. There are many reasons that a parallel process can
> fail during orte_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> orte_session_dir failed
> --> Returned value -1 instead of ORTE_SUCCESS
>
> --------------------------------------------------------------------------
> [hpc-cluster-38 :32635] [0,0,0] ORTE_ERROR_LOG: Error in file
>
> runtime/orte_system_init.c at line 42
> [hpc-cluster-38 :32635] [0,0,0] ORTE_ERROR_LOG: Error in file
>
> runtime/orte_init.c at line 52
> --------------------------------------------------------------------------
> Open RTE was unable to initialize properly. The error occured while
> attempting to orte_init(). Returned value -1 instead of ORTE_SUCCESS.
> --------------------------------------------------------------------------
>
> ====================================
>
> I can not find the file "runtime/orte_init_stage1.c"
>
> It seems that ORTE is not initialized .
> I have built OPEN MPI and installed it correctly .
>
> Why ?
>
> thanks a lot ,
>
> June 16 2008
>
>
>
> > Date: Mon, 16 Jun 2008 19:05:06 +0200
> > From: gentryx_at_[hidden]
> > To: users_at_[hidden]
> > Subject: Re: [OMPI users] help me please, about Open MPI
> >
> > Dear Mister Smith,
> >
> > Thank you for installing Open MPI.
> >
> > On 12:51 Mon 16 Jun , Tony Smith wrote:
> > > I have changed PATH and LD_LIBRARY_PATH:
> >
> > Please be aware that you have to make those changes within your job
> > script. Otherwise they will only affect your local shell.
> >
> > > But, how can I make sure that the application is run by Open MPI
> not by mpich-
> >
> > You could enforce a certain mpirun by using its absolute path, e.g
> > "/ptmp/myname/openmpi123/ompi123_install/bin/mpirun foo" instead of
> > just "mpirun foo".
> >
> > > I deleted /opt/mpich-gm/bin from PATH and added
> >
> > You should not need to delete, just add in front of MPICH.
> >
> > > Would you please help me with that ?
> >
> > I utterly hope I just did.
> >
> > Most sincerely yours ;-)
> > -Andreas
> >
> >
> > --
> > ============================================
> > Andreas Schäfer
> > Cluster and Metacomputing Working Group
> > Friedrich-Schiller-Universität Jena, Germany
> > PGP/GPG key via keyserver
> > I'm a bright... http://www.the-brights.net
> > ============================================
> >
> > (\___/)
> > (+'.'+)
> > (")_(")
> > This is Bunny. Copy and paste Bunny into your
> > signature to help him gain world domination!
>
> Now you can invite friends from Facebook and other groups to join
> you on Windows Live™ Messenger. Add them now!
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems