Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] gfortran bindings apparently not built on mac os leopard
From: Doug Reeder (dlr_at_[hidden])
Date: 2008-06-16 12:42:55


Greg,

In your run_output file you don't appear to be using the openmpi
versions that you built. From your make-install.out file it looks
like your versions are in /usr/local/openmpi/1.2.6-gcc4.0/bin. You
need to use that absolute path or prepend that path to your PATH
environment variable.

Doug Reeder
On Jun 16, 2008, at 9:25 AM, Weirs, V Gregory wrote:

>
>
> I am having trouble building mpif77/mpif90 with gfortran on Mac OS
> 10.5. Or maybe just running. The configure, make all, and make
> install seemed to go just fine, finding my gfortran and apparently
> using it, but the scripts mpif77 and mpif90 give the error that my
> openmpi was not built with fortran bindings. Mpicc and mpicxx don’t
> give this error. Ompi_info says the f77 and f90 bindings were built.
>
> I know that OS X 10.5 comes with openmpi mpicc and mpicxx
> installed, but not fortran bindings, and I was careful to put the
> openmpi I built first in the path.
>
> Some run output (mpif77 —version, ompi_info), config.log,
> configure.log, make.out, make-install.out are in the attached tarball.
>
> Any clues?
>
> Thanks,
> Greg
>
>
> --
> V. Gregory Weirs
> Sandia National Laboratories vgweirs_at_[hidden]
> P.O.Box 5800, MS 0378 phone: 505 845 2032
> Albuquerque, NM 87185-0378 fax: 505 284 0154
> <dig.tar.gz>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users