Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] OpenMPI bug?
From: Gabriele Fatigati (g.fatigati_at_[hidden])
Date: 2008-06-12 03:36:14


Hi,
i have installed OpenMPI 1.2.6, using gcc with bounds checking. But, when i
compile an MPI program, i have many time the same error:

../opal/include/opal/sys/amd64/atomic.h:89: Address in memory: 0x8 ..
0xb
../opal/include/opal/sys/amd64/atomic.h:89: Size: 4 bytes
../opal/include/opal/sys/amd64/atomic.h:89: Element size: 1 bytes
../opal/include/opal/sys/amd64/atomic.h:89: Number of elements: 4
../opal/include/opal/sys/amd64/atomic.h:89: Created at:
class/opal_object.c, line 52
../opal/include/opal/sys/amd64/atomic.h:89: Storage class: static
../opal/include/opal/sys/amd64/atomic.h:89:Bounds error: attempt to
reference memory overrunning the end of an object.
../opal/include/opal/sys/amd64/atomic.h:89: Pointer value: 0x8, Size: 8

Setting the enviroment variable to "-never-fatal", the compile phase, ends
successfull. But, at runtime, i have ever the error above, very much time,
and the program fails, with "undefined status".

Is this an OpenMPI bug?

-- 
Gabriele Fatigati
CINECA Systems & Tecnologies Department
Supercomputing Group
Via Magnanelli 6/3, Casalecchio di Reno (BO) Italy
www.cineca.it Tel: +39 051 6171722
g.fatigati_at_[hidden]