Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libibverbs and openmpi 1.2.6
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-06-05 07:59:00


On Jun 5, 2008, at 7:56 AM, Samuel Sarholz wrote:

>> Nothing changed between 1.2.5 and 1.2.6 with regards to depending
>> on libibverbs.
>
> Ok then I need to check what we did differently when installing both
> versions.
>
> The mpicc wrapper from 1.2.6 links -libverbs.
> (It shows up with mpicc -V).

This suggests that perhaps 1.2.6 was configured with --enable-static
or --disable-dlopen. If either of these two options were used, OMPI
will suck all the plugins to become part of libmpi (and friends), and
therefore the plugins' dependencies will therefore become dependencies
of libmpi (and friends).

-- 
Jeff Squyres
Cisco Systems