Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libibverbs and openmpi 1.2.6
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-06-05 07:20:35


On Jun 5, 2008, at 4:37 AM, Samuel Sarholz wrote:

> we have a some issues with the openmpi 1.2.6 and libibverbs.
>
> We have some machines with Infiniband and some without.
> We compiled openmpi with IB support.
> With OpenMPI 1.2.5 it was no problem running that version on the
> machines without IB.
> However with 1.2.6 the library libibverbs is linked which doen't
> exist on some of the machines.

Nothing changed between 1.2.5 and 1.2.6 with regards to depending on
libibverbs.

> Is there a way to get programs compiled on a IB machine running them
> on machines without IB? (remove the dependency to libibverbs from
> openmpi 1.2.6)

How did you build OMPI? The default configuration in the 1.2 series
should have all the IB support in plugin-modules (i.e., not directly
part of libmpi), and therefore apps should not depend on libibverbs at
all.

Does ldd show that your apps depend on libibverbs?

-- 
Jeff Squyres
Cisco Systems