Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Migrating from lam-mpi
From: jody (jody.xha_at_[hidden])
Date: 2008-05-14 02:45:27


Hi
Actually all you need is in this faq:
http://www.open-mpi.org/faq/?category=running
The analogues to the lam-mpi hostfiles is discussed here
  http://www.open-mpi.org/faq/?category=running#mpirun-host
and here
  http://www.open-mpi.org/faq/?category=running#mpirun-host

There is no booting required.
All you do is start your application with mpirun
  mpirun --hostfile my_hostfile -np 4 my_parallel_application

jody

On Tue, May 13, 2008 at 7:07 PM, Rob Malpass <lug_at_[hidden]> wrote:
> Hi
>
> Could someone help me out with some documentation? I'm searched the faq
> and can't find exactly what I'm after - which is a sort of setup guide.
>
> Thus far, I have a couple of Ubuntu nodes running openmpi-1.2.6. I've
> currently got one setup so it can ssh into the other without a password so I
> guess all I need to do now is to run the job. With lam, there was
> lam-bhost.def but I've not (this is where I need the help) found any
> documentation that talks about the hostfile. The only thing I can find is
>
> http://www.open-mpi.org/faq/?category=running#simple-launch
>
> but with lam, as I recall there were a whole host (no pun intended!) of
> configuration files and some test scripts like recon and lamboot to "boot
> the supercomputer". Are there no such files here?
>
> I hope this doesn't offend - I have searched the faq but I can't find
> exactly what I'm after - is there a setup guide somewhere?
>
> Thanks
>
> Rob
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>