Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] "Permission denied" during MPI installation
From: Alberto Giannetti (albertogiannetti_at_[hidden])
Date: 2008-04-29 16:00:34


Linwei, are you running the command as root?
Try using sudo:
# sudo make install

It will ask you for an administrator password.

On Apr 29, 2008, at 3:54 PM, Linwei Wang wrote:
> Dear all,
>
> I'm new to MPI... I'm trying to install open MPI on my mac (Leopard)..
> But during the installation (with the command "make install")
> it keeps generating errors of "Permission denied".... Anyone has an
> idea of the reasons?
> Part of the output is like:
>
> "
> Making install in etc
> test -z "/usr/local/etc" || ../../config/install-sh -c -d "/usr/local/
> etc"
> /usr/bin/install -c -m 644 openmpi-mca-params.conf /usr/local/etc/
> openmpi-mca-params.conf
> install: /usr/local/etc/openmpi-mca-params.conf: Permission denied
> make[3]: *** [install-data-local] Error 71
> make[2]: *** [install-am] Error 2
> make[1]: *** [install-recursive] Error 1
> make: *** [install-recursive] Error 1
>
> "
>
>
> Thanks in advance!
>
> Linwei
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users