Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] setting the btl_tcp_eager_limit
From: George Bosilca (bosilca_at_[hidden])
Date: 2008-04-29 11:19:31


The btl_tcp_sndbuf and btl_tcp_rcvbuf are limited by the kernel
(usually 128K), so there is no reason to set them to something huge,
if the kernel is unable to support these values. The eager didn't get
modified between 1.1 and 1.2, so it should work as expected.

   george.

On Apr 28, 2008, at 1:20 PM, Jean-Christophe.Mignot_at_[hidden] wrote:

> Hi all,
> We're using a pingpong in order to measure the bandwidth and latency
> available with open MPI.
> In our first experiments done with the 1.1.4 version, we were using
> the
> btl_tcp_eager_limit parameter to modify the eager limit. We've
> upgraded
> to the 1.2.6 version and the limit parameter we fix doesn't seem to be
> taken in account. The value we want to use is 67108864. The command
> line is:
> mpirun -np 2 -machinefile node_file -mca btl_tcp_sndbuf 4194304 -mca
> btl_tcp_rcvbuf 4194304 -mca btl_tcp_eager_limit 67108864 pingpong.
> Is this parameter still useful (ompi_info shows that this parameter is
> still available) ?
> Does anybody have any idea ?
> Thanks in advance.
> JC Mignot and Ludovic Hablot
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users



  • application/pkcs7-signature attachment: smime.p7s