Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] install intel mac with Laopard
From: Doug Reeder (dlr_at_[hidden])
Date: 2008-04-24 11:07:50


Make sure that your compilers are all creaqting code for the same
architecture (i386 or x86-64). ifort usually installs such that the
64 bit version of the compiler is the dfault while the apple gcc
compiler creates i386 output by default. Check the architecture of
the .o files with file *.o and if the gcc output needs to be x86_64
add the -m64 flag to the c and c++ flags. That has worked for me. You
shouldn't need the intel c/c++ compilers. I find the configure error
message to be a little bit cryptic and not very insightful.

Doug Reeder
On Apr 24, 2008, at 7:48 AM, Jeff Squyres (jsquyres) wrote:

> You probably want to use all the intel compilers, not just ifort.
>
> CC=icc
> CXX=icpc
> FC=ifort
> F77=ifort
>
> -jms
> Sent from my PDA. No type good.
>
> -----Original Message-----
> From: Koun SHIRAI [mailto:koun_at_[hidden]]
> Sent: Thursday, April 24, 2008 08:09 AM Eastern Standard Time
> To: Open MPI Users
> Subject: [OMPI users] install intel mac with Laopard
>
> Dear Sir:
>
> I think that this problem must be solved, and maybe some information
> should be given in the archives. But, I miss the right answer in my
> searching area, so please allow me to repeat.
>
> I tried to install openmpi-1.2.5 to a new xserve (Xeon) with Leopard.
> Intel compiler is used for Fortran.
>
> My options for configure was
> CC=/usr/bin/gcc-4.0
> CXX=/usr/bin/g++-4.0
> F77=ifort
> along with
> --with-rsh="ssh -x" --enable-shared --without-cs-fs --without-memory-
> manager
>
> Then, I saw an error message. This says
>
> checking if C and Fortran 77 are link compatible... no
> **********************************************************************
> * It appears that your Fortran 77 compiler is unable to link against
> * object files created by your C compiler. This generally indicates
> * either a conflict between the options specified in CFLAGS and FFLAGS
> * or a problem with the local compiler installation. More
> * information (including exactly what command was given to the
> * compilers and what error resulted when the commands were
> executed) is
> * available in the config.log file in this directory.
> **********************************************************************
> configure: error: C and Fortran 77 compilers are not link compatible.
> Can not continue.
>
> I suppose that the problem is the default selection for the
> architecture (32 or 64 bit). I don't know the correct options. Of
> course, I like to use 64-bit architecture as far as it works.
>
> Best regard,
>
>
> -----------------------
> Koun SHIRAI
> Nanoscience and Nanotechnology Center
> ISIR, Osaka University
> 8-1, Mihogaoka, Ibaraki
> Osaka 567-0047, JAPAN
> PH: +81-6-6879-4302
> FAX: +81-6-6879-8539
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users