Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems with program-execution with OpenMPI: Orted: command not found
From: gildo.rex_at_[hidden]
Date: 2008-04-22 16:07:03


Hi all,

the problem is almost solved!

> >> Make sure you're using the "right" mpirun. If you have both MPICH
> >> and
> >> Open MPI installed, you need to install them into the different
> >> directories.
> >
> > I am sure. I have separate VMware-instances installed in order to
> > avoid any interdependencies. Although I'd like to have MPICH and
> > OpenMPI installed on the same machines in the future to keep my
> > efforts for maintenance small, I invested these endeavors for the
> > first.
> >
> > I would be grateful, if you could advice me about a clean setup for
> > a machine with both MPICH and OpenMPI installed, but I don't want to
> > mix up things here.
>
> All you need to do is install them both into separate prefixes (e.g., /
> opt/openmpi and /opt/mpich). Then when you're using them, ensure that
> your PATH / LD_LIBRARY_PATH is set consistently across all nodes, or
> if using Open MPI, use the options listed in the "What if I can't
> modify my PATH and/or LD_LIBRARY_PATH?" FAQ entry (I'm particularly
> fond of the --enable-mpirun-prefix-by-default option).

Ah, thats good news! My concern is, as I also want to use performance-benchmarks, which are specifically compiled for an installation of MPI, that these benchmarks will not work properly anymore. E.g. Intel IMB Benchmark or mpptest. Would it be a valid solution, to compile these benchmarks new when switching between MPICH and OpenMPI?
>
> >> As for not finding the "orted" on the remote nodes, it simply means
> >> that your PATH / LD_LIBRARY_PATH is not set properly on the remote
> >> nodes. See:
> >>
> >> http://www.open-mpi.org/faq/?category=running#run-prereqs
> >> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
> >> http://www.open-mpi.org/faq/?category=running#mpirun-prefix
> >
> > My PATH should be set properly. As I wrote before:
> >
> > "
> > The "orted"-executable resides as well as the "mpirun"- and
> > "mpiexec"-executables in the directory /home/stephan/openmpi-
> > install. "orted" is also found by "which orted".
> > "
> >
> > I've exported it with the following command:
> >
> > export PATH=/home/stephan/openmpi-install/bin:$PATH
> >
> > Do I get you right:
> >
> > You advice me, to export the /home/stephan/openmpi-install/lib-
> > directory to LD_LIBRARY_PATH too? I can try this at home this evening.
>
> Yes. But the point is that if you're not using something like --
> enable-mpirun-prefix-by-default, then you need to set this PATH and
> LD_LIBRARY_PATH on *all* nodes
> (e.g., in your shell setup files). It is not sufficient to export
> PATH on just the node where you invoke mpirun. See the FAQ entries
> for more details.

I've set the second Path using the command

 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/stephan/openmpi-install/lib/

The test shows up, that the export worked:

  stephan_at_openmpivmwaretest1:~> echo $LD_LIBRARY_PATH
  :/home/stephan/openmpi-install/lib/

(on both nodes)

Then I used the --prefix-option:

  mpirun --prefix /home/stephan/openmpi-install -np 2 --hostfile
  /home/stephan/mpd.hosts /bin/hostname

and suddenly it worked!!!

But why didn't the export work?

Thanks so far to all of you!

Kind regards and good night!

Stephan

-- 
Psst! Geheimtipp: Online Games kostenlos spielen bei den GMX Free Games! 
http://games.entertainment.gmx.net/de/entertainment/games/free