Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems with program-execution with OpenMPI: Orted: command not found
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-04-22 09:02:50


On Apr 22, 2008, at 8:48 AM, Hans Wurst wrote:

>> Make sure you're using the "right" mpirun. If you have both MPICH
>> and
>> Open MPI installed, you need to install them into the different
>> directories.
>
> I am sure. I have separate VMware-instances installed in order to
> avoid any interdependencies. Although I'd like to have MPICH and
> OpenMPI installed on the same machines in the future to keep my
> efforts for maintenance small, I invested these endeavors for the
> first.
>
> I would be grateful, if you could advice me about a clean setup for
> a machine with both MPICH and OpenMPI installed, but I don't want to
> mix up things here.

All you need to do is install them both into separate prefixes (e.g., /
opt/openmpi and /opt/mpich). Then when you're using them, ensure that
your PATH / LD_LIBRARY_PATH is set consistently across all nodes, or
if using Open MPI, use the options listed in the "What if I can't
modify my PATH and/or LD_LIBRARY_PATH?" FAQ entry (I'm particularly
fond of the --enable-mpirun-prefix-by-default option).

>> As for not finding the "orted" on the remote nodes, it simply means
>> that your PATH / LD_LIBRARY_PATH is not set properly on the remote
>> nodes. See:
>>
>> http://www.open-mpi.org/faq/?category=running#run-prereqs
>> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
>> http://www.open-mpi.org/faq/?category=running#mpirun-prefix
>
> My PATH should be set properly. As I wrote before:
>
> "
> The "orted"-executable resides as well as the "mpirun"- and
> "mpiexec"-executables in the directory /home/stephan/openmpi-
> install. "orted" is also found by "which orted".
> "
>
> I've exported it with the following command:
>
> export PATH=/home/stephan/openmpi-install/bin:$PATH
>
> Do I get you right:
>
> You advice me, to export the /home/stephan/openmpi-install/lib-
> directory to LD_LIBRARY_PATH too? I can try this at home this evening.

Yes. But the point is that if you're not using something like --
enable-mpirun-prefix-by-default, then you need to set this PATH and
LD_LIBRARY_PATH on *all* nodes
(e.g., in your shell setup files). It is not sufficient to export
PATH on just the node where you invoke mpirun. See the FAQ entries
for more details.

>> - "--hostfile FILENAME", where FILENAME is a list of a hostfile as
>> described in the FAQ.
>>
>> mpirun --hostfile my_hostfile.txt ...
>
> Yes, my hostfile is named mpd.hosts and has the content
>
> NodeA
> NodeB
>
> , but I guess, that should fit the requirements, right?

Yes, that should be fine. Hosts listed without slot counts are
assumed to have a slot count of 1.

-- 
Jeff Squyres
Cisco Systems