Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems with program-execution with OpenMPI: Orted: command not found
From: Hans Wurst (gildo.rex_at_[hidden])
Date: 2008-04-22 08:48:58


> Make sure you're using the "right" mpirun. If you have both MPICH and
> Open MPI installed, you need to install them into the different
> directories.

I am sure. I have separate VMware-instances installed in order to avoid any interdependencies. Although I'd like to have MPICH and OpenMPI installed on the same machines in the future to keep my efforts for maintenance small, I invested these endeavors for the first.

I would be grateful, if you could advice me about a clean setup for a machine with both MPICH and OpenMPI installed, but I don't want to mix up things here.
>
> As for not finding the "orted" on the remote nodes, it simply means
> that your PATH / LD_LIBRARY_PATH is not set properly on the remote
> nodes. See:
>
> http://www.open-mpi.org/faq/?category=running#run-prereqs
> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
> http://www.open-mpi.org/faq/?category=running#mpirun-prefix

My PATH should be set properly. As I wrote before:

"
The "orted"-executable resides as well as the "mpirun"- and "mpiexec"-executables in the directory /home/stephan/openmpi-install. "orted" is also found by "which orted".
"

I've exported it with the following command:

  export PATH=/home/stephan/openmpi-install/bin:$PATH

Do I get you right:

You advice me, to export the /home/stephan/openmpi-install/lib-directory to LD_LIBRARY_PATH too? I can try this at home this evening.

> >

>
> A few notes about your command line syntax:
>
> - "-np X" specifies how many processes to launch (where X is an
> integer). If you don't specify this, OMPI defaults to as many slots
> are defined in your hostfile.
>
> mpirun -np 4 ....

ok

>
> - "--host LIST", where LIST is a comma-delimited list of hostnames to
> launch on (*instead* of specifying a hostfile).
>
> mpirun --host host1,host2,host3,host4 ....

ok, that's what I tried.
>
> - "--hostfile FILENAME", where FILENAME is a list of a hostfile as
> described in the FAQ.
>
> mpirun --hostfile my_hostfile.txt ...

Yes, my hostfile is named mpd.hosts and has the content

NodeA
NodeB

, but I guess, that should fit the requirements, right?

>
> You can't mix and match these params, like your example:

I didn't try.
>
> mpirun --host -np 2 node0,node1 /bin/hostname

Sorry, I mixed that up, as I do not have the shell-session available at office.
It should correctly be

      mpirun -np 2 --host node0,node1 /bin/hostname

and

      mpirun -np 2 ./mpd.hosts /bin/hostname

where I'm not sure regarding the order of the options.

Kind regards

Stephan

>
>
>
> On Apr 22, 2008, at 4:40 AM, gildo.rex_at_[hidden] wrote:
>
> > Hi Jodi,
> >
> > thanks for the quick answer!
> >
> >> Have you tried the command ompi_info?
> >> What is its output?
> >
> > No, I haven't. I can try this evening, when I'm back home from work.
> >
> >>
> >> Furthermore, the command you gave
> >>> mpirun -np 2 --hostfile /home/stephan/mpd.hosts
> >> is incomplete. There is no executable.
> >
> > Sorry, it should correctly be
> >
> > mpirun -np 2 --hostfile /home/stephan/mpd.hosts /bin/hostname
> >
> > The output shows, that the program is only executed on the local
> > machine. This is the same on each of the machines.
> >
> >>
> >> Try to make sure wether your host file has the correct
> >> format. If i remember correctly Open-MPI does not use
> >> the same format for hostfiles as MPICH.
> >
> > Yes, thats true according to the documentation. There is a
> > possibility to define the number of slots and the max-number of
> > slots in OpenMPI, which I haven't seen in MPICH so far (at least not
> > within the hostfile).
> > But when I use a hostfile without a specification regarding the
> > slots, e.g.
> >
> > shell$ cat my-hosts
> > node0
> > node1
> >
> > (which is the same as in MPICH), it should interpret the default
> > values, i.e. slots=1 and max_slots=unlimited). That should work for
> > that simple test.
> >
> >> See the FAQ for more info
> >> http://www.open-mpi.org/faq/?category=running#mpirun-scheduling
> >
> > I also tried the way to specify the hosts in the command, e.g.
> >
> > mpirun --host -np 2 node0,node1 /bin/hostname
> >
> > but the result is the same. The program runs only on one host.
> >>
> >> If you don't use a hostfile, mpirun will start
> >> all processes on the local machine.
> >
> > Yes, that's what it obviously does. It doesn't recognise the cluster
> > partner in each direction...
> >
> > Kind Regards
> >
> > Stephan
> >
> >> On Tue, Apr 22, 2008 at 8:56 AM, <gildo.rex_at_[hidden]> wrote:
> >>> Dear all,
> >>>
> >>> I wanted to compare MPICH and OpenMPI. MPICH works fine. So I
> >>> installed
> >> OpenMPI the same way (configure, make, make install). The commands
> >> are
> >> found in the OpenMPI installation directory.
> >>>
> >>> When I tried to run programs I was a little bit confused, that there
> >> seems not to be a default hosts-file like in MPICH. I included it
> >> in the
> >> command with "--hostfile".
> >>>
> >>> When I now want to run my first test with
> >>>
> >>> mpirun -np 2 --hostfile /home/stephan/mpd.hosts
> >>>
> >>> I get the error-message:
> >>>
> >>> orted: command not found
> >>>
> >>> The "orted"-executable resides as well as the "mpirun"- and
> >> "mpiexec"-executables in the directory /home/stephan/openmpi-
> >> install. "orted" is also
> >> found by "which orted".
> >>>
> >>> What might be the problem? How does "orted" work? I'm not conscious
> >> about anything equivalent in MPICH...
> >>>
> >>> Thanks in advance for your help!
> >>>
> >>> Kind Regards
> >>>
> >>> Stephan

-- 
Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger