Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with Sun Fortran Install with OpenMPI
From: Terry Dontje (Terry.Dontje_at_[hidden])
Date: 2008-04-21 11:36:06

Looking at the gcc.error attachment that looks to be the one of the
problems talked about in the following faq

If you follow the steps outlined in the above FAQ entry you should be
able to build OpenMPI. If not please drop another
email with the results and I'll see what I can do.


Terry Dontje
Sun Microsystems, Inc.

> Date: Mon, 21 Apr 2008 11:01:50 -0400
> From: cfdman7_at_[hidden]
> Subject: [OMPI users] Problem with Sun Fortran Install with OpenMPI
> To: users_at_[hidden]
> Message-ID: <8CA71D7C32C3AB0-C0-118A_at_[hidden]>
> Content-Type: text/plain; charset="us-ascii"
> Hello,
> I have been attempting to install OpenMPI with the Sun Fortran Compiler
> that is packaged as a part of Sun Studio for x86 architectures for
> about a year and a half now without success. Every time a new version
> of Sun Studio and/or OpenMPI comes out, I have attempted the install
> again with the hopes that whatever has been causing the problem will
> have magically been fixed. However at this point, it appears that
> whatever is causing the install problems is something unkown to your
> development team ... so I figure it is time to report it.
> I am currently trying to install the Sun F90 compiler with
> openmpi-1.2.6 on a 64-bit intel machine running Red Hat Linux
> Enterprise 5. I have also tried this same install on a variety of
> 32-bit intel architectures with 2 other flavors of linux, and I get the
> same errors. I have attached the install script that I use to install
> OpenMPI for each of the FORTRAN packages that I use (OpenMPI installs
> successfully for the 4 other FORTRAN packages in this install script).
> I have also attached 2 sets of output streams with different error
> messages. One of these output streams corresponds to the result that I
> get when setting the C-compiler to gcc in the install script, and the
> other corresponds to setting the C-compiler to the C-compiler that is
> included with Sun Studio.
> Note also that I have not had any problems with getting the Sun
> compilers (Fortran and C) installed with MPICH2, so I am confused as to
> what may be the issue with OpenMPI. I prefer to use OpenMPI, so I would
> like to figure this issue out.
> Thanks in advance,
> Rob