Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problems using Intel MKL with OpenMPI and Pathscale
From: Brian Barrett (brbarret_at_[hidden])
Date: 2008-04-14 09:44:29


On Apr 14, 2008, at 12:30 AM, Åke Sandgren wrote:
> On Sun, 2008-04-13 at 08:00 -0400, Jeff Squyres wrote:
>> Do you get the same error if you disable the memory handling in Open
>> MPI? You can configure OMPI with:
>>
>> --disable-memory-manager
>
> Doesn't help, it still compiles ptmalloc2 and trying to turn off
> ptmaloc2 during runtime doesn't help either.

Jeff had the option slightly wrong. It's actually:

   --without-memory-manager

Because this is a link time decision, during the memory manager code
on / off at runtime won't change anything in terms of interfering with
a compiler's own memory management code.

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/