Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] configure:25579: error: No atomic primitives available for ppc74xx-linux-gnu
From: Brian W. Barrett (brbarret_at_[hidden])
Date: 2008-04-09 15:12:17


On Wed, 9 Apr 2008, Bailey, Eric wrote:

> /home/MPI/openmpi-1.2.6/configure
> --prefix=/home/MPI/openmpi-1.2.6/openmpi-1.2.6-install-7448
> --host=ppc74xx-linux --build=i686-pc-linux-gnu

--host should be formated in the output of config.guess, which would be
something along the lines of processor family-vendor-os. Note that
processor family gets lumped together in pretty large chunks. I'm
guessing that if you could run config.guess on your machine (it requires a
working compiler in some instances), you'd find it would return something
like: powerpc-unknown-linux-gnu. If you pass that as --host, I'm pretty
sure you'll get what you need. If your cross-compilers are named
ppc74xx-linux-gcc, you'll have to then set CC, CXX, FC, and F77
explicitly.

Brian