Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] remote host not accessible
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-04-02 15:31:18


Compiling the OMPI 1.2.5 tarball should be fine.

Can you send the information listed on this page:

     http://www.open-mpi.org/community/help/

Thanks!

On Apr 2, 2008, at 3:05 PM, Danesh Daroui wrote:
> No I compiled it myself. I don't know what you mean but I have built
> it
> from the file
> openmpi-1.2.5.tar.gz. Can it be the problem? As I said everything
> works
> fine locally.
>
> D.
>
>
> Jon Mason skrev:
>> On Tuesday 01 April 2008 04:22:47 pm Danesh Daroui wrote:
>>
>>> You mean I should mount NFS filesystems of slave machine on master
>>> so
>>> their disks can be accessed from a mount point on master? In that
>>> cases,
>>> what moint point on master
>>> shoud it be? Should I configure open-MPI about this mount point?
>>> Can't
>>> it work without mounting? I think it should work since the
>>> processes are
>>> locally run via SSH on remote machines.
>>>
>>
>> Are you running pre-compiled rpm's or did you build from one of the
>> svn trees?
>> If the latter, was it the ompi-trunk tree? If so, can you try the
>> ompi-1.2-svn tree?
>>
>> Thanks,
>> Jon
>>
>>
>>
>>> D.
>>>
>>> Doug Reeder skrev:
>>>
>>>> Danesh,
>>>>
>>>> Do they all have access to the sam file system/physical hard drive.
>>>> You will probably need to NFS mount the filesystem on master on the
>>>> other two systems.
>>>>
>>>> Doug Reeder
>>>>
>>>> On Apr 1, 2008, at 1:46 PM, Danesh Daroui wrote:
>>>>
>>>>> Hi all,
>>>>>
>>>>> I have installed Open-MPI on three machine which runs OpenSUSE
>>>>> and it
>>>>> has been installed successfully. I can submit jobs locally on each
>>>>> machine using "mpirun" and it works fine. I have defined a
>>>>> host file on one of them (master) where I have defined IP
>>>>> address of
>>>>> each machine and number of slots. First when I tried to submit
>>>>> jobs to
>>>>> master it asked for password for SSH connection which showed
>>>>> that master can communicate with slaves. Then I setup all
>>>>> machines to
>>>>> communicate with each other using SSH without password. Now when I
>>>>> submit a job on master, the job just blocks and nothing
>>>>> happens. The program runs locally on each machine but it will
>>>>> not run
>>>>> when I submit it on master to be run on slaves. What can it be?
>>>>>
>>>>> D.
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
>>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
Cisco Systems