Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] SIGSEGV error.
From: Giovani Faccin (giovanifaccin_at_[hidden])
Date: 2008-03-18 07:21:21


Hey Balaji

I'm new at it too, but might be able to help you a bit.

A sigsegv error occurs usually when you try to access something in memory that's not actually there. Like using a pointer that points to nothing. In my short experience with MPI so far, I got this kind of message when I made something wrong with the functions, like for example sending a buffer and, when telling MPI it's size, giving a wrong value. Make sure there's nothing like that on your code.

For the time thing, I think that what you want is the MPI_WTime() function. Check this out:
https://computing.llnl.gov/tutorials/mpi/man/MPI_Wtime.txt

Best,

Giovani

balaji srinivas <balajisrinivas86_at_[hidden]> escreveu:
 hi all,
  I am new to MPI. The outline of my code is
 
 if(r==0)
 function1()
 else if(r==1)
 function2()
 
 where r is the rank and functions are included in the .h files. There are no compilation errors. I get the SIGSEGV error while running.
 Pls help. how to solve this?
 
 2) how to find the execution time of a mpi program. in C we have
 clock_t start=clock() at the beginning and
 
 ((double)clock() - start) / CLOCKS_PER_SEC) at the end.
 
 Thanks in advance.
 
 regards,
 balaji.
 

 _______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users

       
---------------------------------
Abra sua conta no Yahoo! Mail, o único sem limite de espaço para armazenamento!