Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] What architecture? X86_64, that's what architecture!
From: Brian Barrett (brbarret_at_[hidden])
Date: 2008-03-14 17:22:59


On Mar 10, 2008, at 9:15 PM, Jim Hill wrote:

> I'm trying to build a 64-bit 1.2.5 on an 8-core Xeon Mac Pro running
> OS X 10.4.11, with the Portland Group's PGI Workstation 7.1-5
> tools. The configure script works its magic with a couple of
> modifications to account for PGI's tendency to freak out about F90
> modules. Upon make, though, I end up dying with a "Wat
> architecture?" error in opal/mca/backtrace/darwin/MoreBacktrace/
> MoreDebugging/MoreBacktrace.c:128 because (I presume) a 64-bit Xeon
> build isn't a PPC, a PPC64, or an X86.
>
> Is this something that's been seen by others? I'm not the world's
> greatest software stud and this is just a step along the path to my
> real objective, which is making my own software run on this beast
> machine of mine.
>
> Suggestions, tips, and clever insults are welcome. Thanks,

The configure script should have prevented that from happening (and
indeed does with the GNU compilers). I don't have a copy of the PGI
compilers for OS X to test with, so I can't debug this without some
more information. What changes did you make to configure, what
options did you specify to configure, and what was the full output of
configure?

Thanks,

Brian

-- 
   Brian Barrett
   Open MPI developer
   http://www.open-mpi.org/