Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Set GID
From: Jon Mason (jon_at_[hidden])
Date: 2008-03-11 18:04:19


I am getting the following error when I try to run OMPI over my dual
port IB adapter:

--------------------------------------------------------------------------
WARNING: There are more than one active ports on host 'vic20', but the
default subnet GID prefix was detected on more than one of these
ports. If these ports are connected to different physical IB
networks, this configuration will fail in Open MPI. This version of
Open MPI requires that every physically separate IB subnet that is
used between connected MPI processes must have different subnet ID
values.

Please see this FAQ entry for more details:

  http://www.open-mpi.org/faq/?category=openfabrics#ofa-default-subnet-gid

NOTE: You can turn off this warning by setting the MCA parameter
      btl_openib_warn_default_gid_prefix to 0.
--------------------------------------------------------------------------

I understand why it is doing the above based on the description in the
link above, but I cannot seem to find anywhere that will tell me how to
change the GID to something else.

Thanks,
Jon