Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem: openmpi using lam
From: Justus Schwabedal (justus.schwabedal_at_[hidden])
Date: 2008-03-08 06:26:46


I thought LAM/MPI is being merged into openmpi. I think, Im not sure how the implementations are related. I think lam is just a runtime for which now openmpi delivers some support. If not so, I dont understand. However orte is another runtime right? I thought I can switch between those using something like mpi-selector-menu. I think Im lost. How can I use openmpi to run a distributed system efficiently? I dont want to fall back on old LAM/MPI since I want to be modern :o)
Yours, J

-------- Original-Nachricht --------
> Datum: Fri, 7 Mar 2008 13:19:16 -0500
> Von: Jeff Squyres <jsquyres_at_[hidden]>
> An: Open MPI Users <users_at_[hidden]>
> Betreff: Re: [OMPI users] Problem: openmpi using lam

> On Mar 7, 2008, at 11:31 AM, Justus Schwabedal wrote:
>
> > I need advise to get openmpi to work using lam.
>
> I think you're slightly confused -- LAM/MPI and Open MPI are two
> different software projects that implement the same standard (MPI).
> This list is for supporting Open MPI. Another list
> (http://www.lam-mpi.org/mailman/listinfo.cgi/lam
> ) is available for supporting LAM/MPI. You might want to refer to the
> "Getting Help" page on the LAM/MPI site
> (http://www.lam-mpi.org/using/support/
> ). I suspect that your problem has to do with your hostfile, and you
> should check the LAM/MPI user's guide for the answer.
>
> But be aware that LAM/MPI is in maintenance mode -- it is being
> deprecated in favor of Open MPI. See the announcement at the top of
> LAM/MPI's home page.
>
> Good luck.
>
> > For testing I installed it on two machines running opensuse10.3
> > (both atholon 64) connected via ethernet. I then try to run a test
> > script "hello.x" with the following commands:
> > jus_at_cusp:~/Code/Spielwiese/Mpi> make hello
> > mpicc hello.c -o hello.x
> > jus_at_cusp:~/Code/Spielwiese/Mpi> lamboot mfile
> >
> > LAM 7.1.4/MPI 2 C++/ROMIO - Indiana University
> >
> > Enter passphrase for key '/cusp/jus/.ssh/id_rsa':
> > Enter passphrase for key '/cusp/jus/.ssh/id_rsa':
> > jus_at_cusp:~/Code/Spielwiese/Mpi> lamnodes
> > n0 cusp:1:origin,this_node
> > n1 neutrino.stat.physik.uni-potsdam.de:1:
> > jus_at_cusp:~/Code/Spielwiese/Mpi> mpirun -np 2 hello.x
> > Process 0 on cusp out of 2
> > Process 1 on cusp out of 2
> >
> > The jobs are thus wrapped only on the node "cusp", not on both. I
> > have no clue why this is.
> > Thanks, Justus
> > --
> > Psst! Geheimtipp: Online Games kostenlos spielen bei den GMX Free
> > Games!
> > http://games.entertainment.gmx.net/de/entertainment/games/free
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> Cisco Systems
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger