Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] -prefix option to mpirun.
From: Ashley Pittman (apittman_at_[hidden])
Date: 2008-03-04 12:34:42


Fantastic! I've rebuilt with the flag and it worked as expected, thank
you for you speedy response.

Ashley,

On Tue, 2008-03-04 at 12:20 -0500, Tim Prins wrote:
> Thanks for the report of the broken link. It is now fixed. I have also
> added a paragraph about --enable-mpirun-prefix-by-default to
> http://www.open-mpi.org/faq/?category=running#mpirun-prefix
>
> Tim
>
> Ashley Pittman wrote:
> > That looks like just what I need, thank you for the quick response.
> >
> > The closest I could find in the FAQ is this entry which has a broken
> > link to the second entry.
> >
> > http://www.open-mpi.org/faq/?category=running#mpirun-prefix
> >
> > http://www.open-mpi.org/faq/?category=mpi-aps#why-no-rpath
> >
> > I need to avoid modifying ld.so.conf or setting up aliases so openmpi
> > can be properly loaded and unloaded with the modules command.
> >
> > Ashley,
> >
> > On Tue, 2008-03-04 at 09:37 -0500, Tim Prins wrote:
> >> Hi Ashley,
> >>
> >> Yes, you can have this done automatically. Just use the
> >> '--enable-mpirun-prefix-by-default' option to configure.
> >>
> >> I'm actually a bit surprised this is not in the FAQ. I'll have to add it.
> >>
> >> Hope this helps,
> >>
> >> Tim
> >>
> >> Ashley Pittman wrote:
> >>> Hello,
> >>>
> >>> I work for medium sized UK based ISV and am packaging open-mpi so that
> >>> is can be made available as an option to our users, so far I've been
> >>> very impressed by how smoothly things have gone but I've got one problem
> >>> which doesn't seem to be covered by the FAQ.
> >>>
> >>> We install openmpi to /opt/openmpi-1.2.5 and are using the modules
> >>> command to select which mpi to use, the modules command correctly sets
> >>> PATH to pick up mpicc and mpirun on the head node however the issue
> >>> comes with running a job, users need to specify -prefix on the mpirun
> >>> command line. Is there a way to specify this in the environment so I
> >>> could make it happen automatically as part of the modules environment?
> >>>
> >>> I've searched the archives for this, the closest I can find is this
> >>> exchange in 2006, if I specify a full path to mpirun then it does the
> >>> right thing but is there a way to extend this functionality to the case
> >>> where mpirun is run from path?
> >>> http://www.open-mpi.org/community/lists/users/2006/01/0480.php
> >>>
> >>> Yours, Ashley Pittman.
> >>>
> >>> _______________________________________________
> >>> users mailing list
> >>> users_at_[hidden]
> >>> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >> _______________________________________________
> >> users mailing list
> >> users_at_[hidden]
> >> http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users